summaryrefslogtreecommitdiffstats
path: root/package/matchbox/matchbox-panel
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2010-04-01 11:10:12 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-03 13:45:23 +0200
commitf94830d0e5a409b2e2dc30a4e002c180fe09ec4e (patch)
treeacf0f7e9f84d00bba862f0d36cf6fa1f2a2f9e2a /package/matchbox/matchbox-panel
parentcb08cd64f0fe89d9551052cafeae96045441df51 (diff)
downloadbuildroot-novena-f94830d0e5a409b2e2dc30a4e002c180fe09ec4e.tar.gz
buildroot-novena-f94830d0e5a409b2e2dc30a4e002c180fe09ec4e.zip
matchbox: convert to autotools, fix build with start-notification, libxft
Signed-off-by: Will Wagner <will_wagner@carallon.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/matchbox/matchbox-panel')
-rw-r--r--package/matchbox/matchbox-panel/matchbox-panel-0.9.3-index-is-legacy.patch20
-rw-r--r--package/matchbox/matchbox-panel/matchbox-panel.mk24
2 files changed, 44 insertions, 0 deletions
diff --git a/package/matchbox/matchbox-panel/matchbox-panel-0.9.3-index-is-legacy.patch b/package/matchbox/matchbox-panel/matchbox-panel-0.9.3-index-is-legacy.patch
new file mode 100644
index 000000000..925c326e7
--- /dev/null
+++ b/package/matchbox/matchbox-panel/matchbox-panel-0.9.3-index-is-legacy.patch
@@ -0,0 +1,20 @@
+Replace the legacy index() with strchr()
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ applets/mb-applet-menu-launcher.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: matchbox-panel-0.9.3/applets/mb-applet-menu-launcher.c
+===================================================================
+--- matchbox-panel-0.9.3.orig/applets/mb-applet-menu-launcher.c
++++ matchbox-panel-0.9.3/applets/mb-applet-menu-launcher.c
+@@ -280,7 +280,7 @@
+ DBG("\tkey %s ", key);
+ if (*(++p) == '"') { p++; tc = sc; } /* skip "'s */
+ val = p;
+- while(index(tc,*p) == NULL)
++ while(strchr(tc,*p) == NULL)
+ {
+ if (*p == '\\' && *(p+1) == '"') p++; /* skip \" */
+ p++;
diff --git a/package/matchbox/matchbox-panel/matchbox-panel.mk b/package/matchbox/matchbox-panel/matchbox-panel.mk
new file mode 100644
index 000000000..573e3231d
--- /dev/null
+++ b/package/matchbox/matchbox-panel/matchbox-panel.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# MatchBox Panel
+#
+#############################################################
+
+MATCHBOX_PANEL_VERSION = 0.9.3
+MATCHBOX_PANEL_SOURCE = matchbox-panel-$(MATCHBOX_PANEL_VERSION).tar.bz2
+MATCHBOX_PANEL_SITE = http://matchbox-project.org/sources/matchbox-panel/$(MATCHBOX_PANEL_VERSION)
+MATCHBOX_PANEL_DEPENDENCIES = matchbox-lib
+MATCHBOX_PANEL_CONF_OPT = --enable-expat
+
+#############################################################
+
+ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
+ MATCHBOX_PANEL_CONF_OPT+=--enable-startup-notification
+ MATCHBOX_PANEL_DEPENDENCIES+=startup-notification matchbox-startup-monitor
+else
+ MATCHBOX_PANEL_CONF_OPT+=--disable-startup-notification
+endif
+
+#############################################################
+
+$(eval $(call AUTOTARGETS,package/matchbox,matchbox-panel))