summaryrefslogtreecommitdiffstats
path: root/package/matchbox/matchbox-fakekey
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2010-04-01 11:10:12 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-03 13:45:23 +0200
commitf94830d0e5a409b2e2dc30a4e002c180fe09ec4e (patch)
treeacf0f7e9f84d00bba862f0d36cf6fa1f2a2f9e2a /package/matchbox/matchbox-fakekey
parentcb08cd64f0fe89d9551052cafeae96045441df51 (diff)
downloadbuildroot-novena-f94830d0e5a409b2e2dc30a4e002c180fe09ec4e.tar.gz
buildroot-novena-f94830d0e5a409b2e2dc30a4e002c180fe09ec4e.zip
matchbox: convert to autotools, fix build with start-notification, libxft
Signed-off-by: Will Wagner <will_wagner@carallon.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/matchbox/matchbox-fakekey')
-rw-r--r--package/matchbox/matchbox-fakekey/matchbox-fakekey.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk b/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk
new file mode 100644
index 000000000..bcb6cc04d
--- /dev/null
+++ b/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# MatchBox Fakekey
+#
+#############################################################
+
+MATCHBOX_FAKEKEY_VERSION = 0.1
+MATCHBOX_FAKEKEY_SOURCE = libfakekey-$(MATCHBOX_FAKEKEY_VERSION).tar.bz2
+MATCHBOX_FAKEKEY_SITE = http://matchbox-project.org/sources/libfakekey/$(MATCHBOX_FAKEKEY_VERSION)
+MATCHBOX_FAKEKEY_LIBTOOL_PATCH = NO
+MATCHBOX_FAKEKEY_INSTALL_STAGING = YES
+MATCHBOX_FAKEKEY_DEPENDENCIES = matchbox-lib xlib_libXtst
+MATCHBOX_FAKEKEY_CONF_OPT = --enable-expat
+
+define MATCHBOX_FAKEKEY_POST_CONFIGURE_FIXES
+ $(SED) 's:-I[^$$].*/usr/include/freetype2:-I/usr/include/freetype2:' $(STAGING_DIR)/usr/lib/pkgconfig/libmb.pc
+ $(SED) 's:^SUBDIRS = fakekey src tests.*:SUBDIRS = fakekey src:g' $(MATCHBOX_FAKEKEY_DIR)/Makefile
+endef
+
+MATCHBOX_FAKEKEY_POST_CONFIGURE_HOOKS += MATCHBOX_FAKEKEY_POST_CONFIGURE_FIXES
+
+#############################################################
+
+$(eval $(call AUTOTARGETS,package/matchbox,matchbox-fakekey))