summaryrefslogtreecommitdiffstats
path: root/package/makedisk
diff options
context:
space:
mode:
authorbnewbold <bnewbold@robocracy.org>2013-07-15 00:03:47 +0000
committerbnewbold <bnewbold@robocracy.org>2013-07-15 00:03:47 +0000
commit6c94ef706e8b4450a8a83b0f1cf80a74d683d4a0 (patch)
tree051fb87d5de9421e798baf709d578e246674d347 /package/makedisk
parent6b2a0e0c9b297396a9c0841905fa31275a38a0e3 (diff)
downloadbuildroot-novena-6c94ef706e8b4450a8a83b0f1cf80a74d683d4a0.tar.gz
buildroot-novena-6c94ef706e8b4450a8a83b0f1cf80a74d683d4a0.zip
packages: add genfatfs and makedisk (both host tools)
Diffstat (limited to 'package/makedisk')
-rw-r--r--package/makedisk/Config.in.host7
-rw-r--r--package/makedisk/makedisk.mk29
2 files changed, 36 insertions, 0 deletions
diff --git a/package/makedisk/Config.in.host b/package/makedisk/Config.in.host
new file mode 100644
index 000000000..cb1df3760
--- /dev/null
+++ b/package/makedisk/Config.in.host
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_HOST_MAKEDISK
+ bool "host makedisk"
+ help
+ SD Card image generator (multi-partition)
+
+ https://github.com/sutajiokousagi/makedisk
+
diff --git a/package/makedisk/makedisk.mk b/package/makedisk/makedisk.mk
new file mode 100644
index 000000000..4797f07f4
--- /dev/null
+++ b/package/makedisk/makedisk.mk
@@ -0,0 +1,29 @@
+################################################################################
+#
+# maketools
+#
+################################################################################
+
+MAKEDISK_VERSION = c343d8e8176482cf2302ea5d8e1974e9178eab83
+MAKEDISK_SITE = https://github.com/sutajiokousagi/makedisk/tarball/$(MAKEDISK_VERSION)
+
+define MAKEDISK_BUILD_CMDS
+ $(MAKE) -C $(@D) \
+ HOSTCC="$(TARGET_CC)" \
+ HOSTCFLAGS="$(TARGET_CFLAGS)" \
+ HOSTLDFLAGS="$(TARGET_LDFLAGS)" \
+ HOSTSTRIP=true
+endef
+
+define HOST_MAKEDISK_BUILD_CMDS
+ $(MAKE1) -C $(@D) \
+ HOSTCC="$(HOSTCC)" \
+ HOSTCFLAGS="$(HOST_CFLAGS)" \
+ HOSTLDFLAGS="$(HOST_LDFLAGS)"
+endef
+
+define HOST_MAKEDISK_INSTALL_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/makedisk $(HOST_DIR)/usr/bin/makedisk
+endef
+
+$(eval $(host-generic-package))