summaryrefslogtreecommitdiffstats
path: root/package/lzo
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/lzo
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
downloadbuildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.tar.gz
buildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.zip
facelift step number two
Diffstat (limited to 'package/lzo')
-rw-r--r--package/lzo/lzo-cross-compile.patch43
-rw-r--r--package/lzo/lzo.mk3
2 files changed, 44 insertions, 2 deletions
diff --git a/package/lzo/lzo-cross-compile.patch b/package/lzo/lzo-cross-compile.patch
new file mode 100644
index 000000000..68a3d0449
--- /dev/null
+++ b/package/lzo/lzo-cross-compile.patch
@@ -0,0 +1,43 @@
+For some reason the lzo autoconf script uses a local macro that does
+a test for cross-compiles, and assumes that if the build target name
+and the host target name are the same that --host was not specified to
+the configure script. In the uClibc buildroot, this is not the case.
+
+--- lzo-1.08/aclocal.m4 2002-07-12 18:31:52.000000000 -0700
++++ lzo-1.08/aclocal.m4.new 2004-03-10 15:32:42.000000000 -0700
+@@ -205,12 +205,6 @@
+ [
+ AC_REQUIRE([AC_PROG_CC])
+
+-if test "X$cross_compiling" = Xyes; then
+- if test "X$build" = "X$host"; then
+- AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
+- fi
+-fi
+-
+ ])
+
+
+--- lzo-1.08/configure-dist 2004-03-11 02:18:28.000000000 -0600
++++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
+@@ -2282,13 +2282,13 @@
+
+
+
+-if test "X$cross_compiling" = Xyes; then
+- if test "X$build" = "X$host"; then
+- { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
+-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
+- { (exit 1); exit 1; }; }
+- fi
+-fi
++#if test "X$cross_compiling" = Xyes; then
++# if test "X$build" = "X$host"; then
++# { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
++#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
++# { (exit 1); exit 1; }; }
++# fi
++#fi
+
+
+
diff --git a/package/lzo/lzo.mk b/package/lzo/lzo.mk
index 48e9d7b5d..1e603635e 100644
--- a/package/lzo/lzo.mk
+++ b/package/lzo/lzo.mk
@@ -12,7 +12,6 @@ LZO_SITE:=http://ftp.debian.org/debian/pool/main/l/lzo
#LZO_SITE:=http://www.oberhumer.com/opensource/lzo/download
LZO_DIR:=$(BUILD_DIR)/lzo-1.08
LZO_CAT:=zcat
-LZO_PATCH:=$(SOURCE_DIR)/lzo-cross-compile.patch
$(DL_DIR)/$(LZO_SOURCE):
$(WGET) -P $(DL_DIR) $(LZO_SITE)/$(LZO_SOURCE)
@@ -21,7 +20,7 @@ lzo-source: $(DL_DIR)/$(LZO_SOURCE)
$(LZO_DIR)/.unpacked: $(DL_DIR)/$(LZO_SOURCE)
$(LZO_CAT) $(DL_DIR)/$(LZO_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- cat $(LZO_PATCH) | patch -p1 -d $(LZO_DIR)
+ toolchain/patch-kernel.sh $(LZO_DIR) package/lzo/ lzo-\*.patch
touch $(LZO_DIR)/.unpacked
LZO_CONFIG_SHARED:=--disable-shared