summaryrefslogtreecommitdiffstats
path: root/package/luaposix
diff options
context:
space:
mode:
authorAssaf Inbal <shmuelzon@gmail.com>2013-06-20 07:40:50 +0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-20 12:04:39 +0200
commit6618ab94361a978dbbf0545c2ac5cac5be8f64ac (patch)
tree4af4792e2be218ac3eeeb5d1206e69f1b280180e /package/luaposix
parenta869bf8c84cda6d7b21950a6653ad9a80b90be4f (diff)
downloadbuildroot-novena-6618ab94361a978dbbf0545c2ac5cac5be8f64ac.tar.gz
buildroot-novena-6618ab94361a978dbbf0545c2ac5cac5be8f64ac.zip
luaposix: New package
Luaposix is a Lua frontend to posix functions. Signed-off-by: Assaf Inbal <shmuelzon@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/luaposix')
-rw-r--r--package/luaposix/Config.in11
-rw-r--r--package/luaposix/luaposix-remove-lua-header-check.patch16
-rw-r--r--package/luaposix/luaposix.mk15
3 files changed, 42 insertions, 0 deletions
diff --git a/package/luaposix/Config.in b/package/luaposix/Config.in
new file mode 100644
index 000000000..412e07f13
--- /dev/null
+++ b/package/luaposix/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LUAPOSIX
+ bool "luaposix"
+ help
+ luaposix is a POSIX binding, including curses, for Lua 5.1
+ and 5.2; Like most libraries it simply binds to C APIs on
+ the underlying system, so it won't work on a non-POSIX
+ system. However, it does try to detect the level of POSIX
+ conformance of the underlying system and bind only available
+ APIs
+
+ https://github.com/luaposix/luaposix
diff --git a/package/luaposix/luaposix-remove-lua-header-check.patch b/package/luaposix/luaposix-remove-lua-header-check.patch
new file mode 100644
index 000000000..7909b9175
--- /dev/null
+++ b/package/luaposix/luaposix-remove-lua-header-check.patch
@@ -0,0 +1,16 @@
+Checking the Lua version inside the headers requires compiling a small
+C program. However, autoconf will raise an error when attempting to do so
+while cross-compiling. Hence, this specific test is removed.
+
+Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
+--- a/configure.ac 2013-06-20 07:23:27.943091833 +0300
++++ b/configure.ac 2013-06-20 07:23:30.644441710 +0300
+@@ -105,7 +105,7 @@
+
+ dnl Lua 5.1 or 5.2
+ AX_PROG_LUA(501, 503)
+ AX_LUA_HEADERS
+-AX_LUA_HEADERS_VERSION(501, 503)
++#AX_LUA_HEADERS_VERSION(501, 503)
+ AC_SUBST(LUA)
+ AC_SUBST(LUA_INCLUDE)
diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
new file mode 100644
index 000000000..1d1ee6a74
--- /dev/null
+++ b/package/luaposix/luaposix.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# luaposix
+#
+################################################################################
+
+LUAPOSIX_VERSION = 5.1.20
+LUAPOSIX_SITE = https://github.com/downloads/luaposix/luaposix
+LUAPOSIX_LICENSE = MIT
+LUAPOSIX_LICENSE_FILES = COPYING
+LUAPOSIX_DEPENDENCIES = lua host-lua
+LUAPOSIX_CONF_OPT = --libdir="/usr/lib/lua" --datarootdir="/usr/share/lua"
+LUAPOSIX_AUTORECONF = YES
+
+$(eval $(autotools-package))