summaryrefslogtreecommitdiffstats
path: root/package/luafilesystem
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-05-10 14:42:13 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-06-05 21:53:52 +0200
commita8495cdfcd46267e6782d174429231a49c22a23f (patch)
tree30af140d38067cda000529072ba63bc31ab21e8a /package/luafilesystem
parentfa11d8d8306646714b81f56a04ecde07f3aec623 (diff)
downloadbuildroot-novena-a8495cdfcd46267e6782d174429231a49c22a23f.tar.gz
buildroot-novena-a8495cdfcd46267e6782d174429231a49c22a23f.zip
New lua module: luafilesystem
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/luafilesystem')
-rw-r--r--package/luafilesystem/Config.in9
-rw-r--r--package/luafilesystem/luafilesystem.mk27
2 files changed, 36 insertions, 0 deletions
diff --git a/package/luafilesystem/Config.in b/package/luafilesystem/Config.in
new file mode 100644
index 000000000..ba6387831
--- /dev/null
+++ b/package/luafilesystem/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LUAFILESYSTEM
+ bool "luafilesystem"
+ depends on BR2_LARGEFILE
+ depends on BR2_PACKAGE_LUA_SHARED_LIBRARY
+ help
+ LuaFileSystem offers a portable way to access
+ the underlying directory structure and file attributes.
+
+ http://luaforge.net/projects/luafilesystem/
diff --git a/package/luafilesystem/luafilesystem.mk b/package/luafilesystem/luafilesystem.mk
new file mode 100644
index 000000000..a27080cd6
--- /dev/null
+++ b/package/luafilesystem/luafilesystem.mk
@@ -0,0 +1,27 @@
+#############################################################
+#
+# luafilesystem
+#
+#############################################################
+
+LUAFILESYSTEM_VERSION = 1.5.0
+LUAFILESYSTEM_SITE = http://github.com/downloads/keplerproject/luafilesystem
+LUAFILESYSTEM_DEPENDENCIES = lua
+
+define LUAFILESYSTEM_BUILD_CMDS
+ $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endef
+
+define LUAFILESYSTEM_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/src/lfs.so $(TARGET_DIR)/usr/lib/lua/lfs.so
+endef
+
+define LUAFILESYSTEM_UNINSTALL_TARGET_CMDS
+ rm -f "$(TARGET_DIR)/usr/lib/lua/lfs.so"
+endef
+
+define LUAFILESYSTEM_CLEAN_CMDS
+ $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(call GENTARGETS,package,luafilesystem))