summaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-03-11 15:24:56 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-13 14:17:09 +0100
commitd77ff16b11bde9832914224794ca07312711d0bd (patch)
treeba483cdc29ec86d233c8e6cd716b045743b87c0e /package/lua
parentaa9f6a9b133104b54c1abc0db203c30b6c0ea364 (diff)
downloadbuildroot-novena-d77ff16b11bde9832914224794ca07312711d0bd.tar.gz
buildroot-novena-d77ff16b11bde9832914224794ca07312711d0bd.zip
lua: fix non-shared library build
Building without BR2_PACKAGE_LUA_SHARED_LIBRARY failed because of missing -ldl. dl is used by lua's dynamic module loading. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/lua.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index 30e95b457..aa0b4bf3c 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -10,9 +10,10 @@ LUA_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
LUA_MYCFLAGS += -fPIC
- LUA_MYLIBS += -ldl
endif
+LUA_MYLIBS += -ldl
+
ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_READLINE),y)
LUA_DEPENDENCIES = readline ncurses
LUA_MYLIBS += -lreadline -lhistory -lncurses