summaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-02 23:22:45 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-02 23:22:45 +0200
commit8471827f32e92c12e90ba2a534d00873845617c2 (patch)
treeae600adce038d684654574c2b38d36c7feaa4a5a /package/lua
parent4439d388907066ab58fc1753eb07c40dcc98fcf6 (diff)
downloadbuildroot-novena-8471827f32e92c12e90ba2a534d00873845617c2.tar.gz
buildroot-novena-8471827f32e92c12e90ba2a534d00873845617c2.zip
lua: fix pkgconfig installation
install -D needs the destination filename, not just it's directory, otherwise we end up with a pkgconfig file instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/lua.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index 9b2302144..d66be9fd3 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -39,7 +39,7 @@ endif
define LUA_INSTALL_STAGING_CMDS
$(INSTALL) -m 0644 -D $(@D)/etc/lua.pc \
- $(STAGING_DIR)/usr/lib/pkgconfig
+ $(STAGING_DIR)/usr/lib/pkgconfig/lua.pc
$(INSTALL) $(@D)/src/liblua.a $(STAGING_DIR)/usr/lib
$(INSTALL) $(@D)/src/lua $(STAGING_DIR)/usr/bin
$(INSTALL) $(@D)/src/luac $(STAGING_DIR)/usr/bin