summaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-11-17 22:19:26 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-17 22:19:26 +0100
commit684f208ecf1da23ce7013a91a69adb2ff7161715 (patch)
treecd1ffb0edc57062715436b2f0e9cfd3dac72e912 /package/lua
parent56cbd27a4c14709163ec5437c41a8a046631b8c9 (diff)
downloadbuildroot-novena-684f208ecf1da23ce7013a91a69adb2ff7161715.tar.gz
buildroot-novena-684f208ecf1da23ce7013a91a69adb2ff7161715.zip
lua: don't be fancy when creating shared library
(Possibly) fixes #5354 The lua shared library patch was creating the shared library with -nostdlib -lgcc for some unknown reason, which most likely is the reason for the link issue reported in #5354. Fix it by dropping these arguments, so gcc gets to figure out itself what dependencies are needed. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/lua-02-shared-libs-for-lua.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/lua/lua-02-shared-libs-for-lua.patch b/package/lua/lua-02-shared-libs-for-lua.patch
index 454e66002..97a70684f 100644
--- a/package/lua/lua-02-shared-libs-for-lua.patch
+++ b/package/lua/lua-02-shared-libs-for-lua.patch
@@ -39,7 +39,7 @@ Index: b/src/Makefile
-$(LUA_T): $(LUA_O) $(LUA_A)
- $(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+$(LUA_SO): $(CORE_O) $(LIB_O)
-+ $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $? -nostdlib -lgcc
++ $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
+ ln -fs $@.$(PKG_VERSION) $@
+
+$(LUA_T): $(LUA_O) $(LUA_SO)