summaryrefslogtreecommitdiffstats
path: root/package/lttng-tools
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-01-31 20:40:03 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-31 23:46:06 +0100
commita7dfa29d128a2edf91f33f1d66dc55fa41ac0b4a (patch)
tree3cea598006e435af80688c2a303c2f62d89cc25d /package/lttng-tools
parentdc77b0824e6d7adf40b4543243cbca8d8d03695b (diff)
downloadbuildroot-novena-a7dfa29d128a2edf91f33f1d66dc55fa41ac0b4a.tar.gz
buildroot-novena-a7dfa29d128a2edf91f33f1d66dc55fa41ac0b4a.zip
lttng-tools: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lttng-tools')
-rw-r--r--package/lttng-tools/Config.in20
-rw-r--r--package/lttng-tools/lttng-tools.mk11
2 files changed, 31 insertions, 0 deletions
diff --git a/package/lttng-tools/Config.in b/package/lttng-tools/Config.in
new file mode 100644
index 000000000..cc7496605
--- /dev/null
+++ b/package/lttng-tools/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LTTNG_TOOLS
+ bool "lttng-tools"
+ depends on BR2_PACKAGE_LTTNG_MODULES
+ select BR2_PACKAGE_LIBURCU
+ select BR2_PACKAGE_POPT
+ select BR2_PACKAGE_LTTNG_LIBUST
+ help
+ Userspace utilities for the LTTng 2.0 tracing
+ infrastructure.
+
+ Those utilities are required on the target system to start
+ and stop tracing sessions. Analysis of the trace can be done
+ on the host machine using the babeltrace utility. This
+ utility is automatically built by Buildroot in
+ $(O)/host/usr/bin/babeltrace, as a dependency of
+ lttng-tools. However, there is also a lttng-babeltrace
+ package for the target, if babeltrace on the target is
+ interesting.
+
+ http://lttng.org
diff --git a/package/lttng-tools/lttng-tools.mk b/package/lttng-tools/lttng-tools.mk
new file mode 100644
index 000000000..9e874808c
--- /dev/null
+++ b/package/lttng-tools/lttng-tools.mk
@@ -0,0 +1,11 @@
+LTTNG_TOOLS_VERSION = 2.0-pre15
+LTTNG_TOOLS_SITE = http://lttng.org/files/bundles/20111214/
+LTTNG_TOOLS_SOURCE = lttng-tools-$(LTTNG_TOOLS_VERSION).tar.bz2
+
+# The host-lttng-babeltrace technically isn't a required build
+# dependency. However, having the babeltrace utilities built for the
+# host is very useful, since those tools allow to convert the binary
+# trace format into an human readable format.
+LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace lttng-libust
+
+$(eval $(call AUTOTARGETS))