summaryrefslogtreecommitdiffstats
path: root/package/lttng-tools
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2013-01-20 23:05:13 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-21 10:48:54 +0100
commit45210100468e9d7f80335c9d181997384ea5fa62 (patch)
tree3995200f59638a95dc33fd3bf03ada08500a2082 /package/lttng-tools
parentc60b67320f31cbc77727ceb7273311611a2a9b89 (diff)
downloadbuildroot-novena-45210100468e9d7f80335c9d181997384ea5fa62.tar.gz
buildroot-novena-45210100468e9d7f80335c9d181997384ea5fa62.zip
lttng-tools: fix version bumping to 2.1.1"
* re-introduce lttng-tools-no-sync-file-range-in-uclibc.patch (merged upstream just after the 2.1.1 release) Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lttng-tools')
-rw-r--r--package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
new file mode 100644
index 000000000..fcaaa3e32
--- /dev/null
+++ b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
@@ -0,0 +1,51 @@
+Make sync_file_range() usage optional
+
+Under uClibc, sync_file_range() is not available under all
+architectures, so we fall back to fdatasync() in this case.
+
+Inspired by the patch done by Thomas Petazzoni for the
+2.0-pre25 version.
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+---
+ configure.ac | 2 +-
+ src/common/compat/fcntl.h | 5 +++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5808c79..065b9cf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
+ )
+ ])
+ AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [test "x$lttng_ust_ctl_found" = xyes])
+-AC_CHECK_FUNCS([sched_getcpu sysconf])
++AC_CHECK_FUNCS([sched_getcpu sysconf sync_file_range])
+
+ # check for dlopen
+ AC_CHECK_LIB([dl], [dlopen],
+@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],[
+ ])
+
+ AS_ECHO()
+-
+diff --git a/src/common/compat/compat-fcntl.c b/src/common/compat/compat-fcntl.c
+index 5a1c757..7ff63a3 100644
+--- a/src/common/compat/compat-fcntl.c
++++ b/src/common/compat/compat-fcntl.c
+@@ -23,7 +23,11 @@
+ int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
+ unsigned int flags)
+ {
++#ifdef HAVE_SYNC_FILE_RANGE
+ return sync_file_range(fd, offset, nbytes, flags);
++#else
++ return fdatasync(fd);
++#endif
+ }
+
+ #endif /* __linux__ */
+--
+1.8.0.3
+