summaryrefslogtreecommitdiffstats
path: root/package/ltrace
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-13 22:41:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-20 22:34:27 +0200
commit728e43534d6c9fc50336ed1c7c95e855ecd2b438 (patch)
tree6a99d2cb9e6bcc958c6936ccdba919d907f42141 /package/ltrace
parentbdc9c05f4450b0ca1e4bfd8edc52c4f9537e576a (diff)
downloadbuildroot-novena-728e43534d6c9fc50336ed1c7c95e855ecd2b438.tar.gz
buildroot-novena-728e43534d6c9fc50336ed1c7c95e855ecd2b438.zip
ltrace: fix build failure
ltrace failed to build because of missing arguments to gcc to find the header files. This is due to the fact that the existing ltrace.mk was setting CC and LD at build time to incorrect values. Keeping the values set at configure time is just the right thing to do. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ltrace')
-rw-r--r--package/ltrace/ltrace.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/ltrace/ltrace.mk b/package/ltrace/ltrace.mk
index c99f223ac..4a6811d86 100644
--- a/package/ltrace/ltrace.mk
+++ b/package/ltrace/ltrace.mk
@@ -54,8 +54,7 @@ $(LTRACE_DIR)/.configured: $(LTRACE_DIR)/.patched
touch $@
$(LTRACE_DIR)/$(LTRACE_BINARY): $(LTRACE_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld ARCH=$(LTRACE_ARCH) \
- -C $(LTRACE_DIR)
+ $(MAKE) ARCH=$(LTRACE_ARCH) -C $(LTRACE_DIR)
$(TARGET_DIR)/$(LTRACE_TARGET_BINARY): $(LTRACE_DIR)/$(LTRACE_BINARY)
#$(MAKE) DESTDIR=$(TARGET_DIR) ARCH=$(LTRACE_ARCH) -C $(LTRACE_DIR) install