summaryrefslogtreecommitdiffstats
path: root/package/ltp-testsuite
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-08-08 07:53:10 +0000
committerEric Andersen <andersen@codepoet.org>2005-08-08 07:53:10 +0000
commitd70e7f4f1e662622ed9809948a0f585fc390982b (patch)
tree50ed84db09c0ea726ca4a91bdd50406e3bb7a00f /package/ltp-testsuite
parent06c5ff4e823cab16987d89c585ef2de4a3db2a7b (diff)
downloadbuildroot-novena-d70e7f4f1e662622ed9809948a0f585fc390982b.tar.gz
buildroot-novena-d70e7f4f1e662622ed9809948a0f585fc390982b.zip
Prevent problems with fakeroot possibly trying to use stale host filesystem
inodes by carefully regenerating fakeroot.env from package specific files.
Diffstat (limited to 'package/ltp-testsuite')
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index edf2ffdde..0d4082de2 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -15,26 +15,26 @@ $(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
-$(LTP_TESTSUITE_DIR)/.unpacked: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
+$(LTP_TESTSUITE_DIR)/Makefile: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(LTP_TESTSUITE_ROOT) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ ltp-testsuite\*.patch
- touch $(LTP_TESTSUITE_DIR)/.unpacked
+ touch -c $(LTP_TESTSUITE_DIR)/Makefile
-$(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01: $(LTP_TESTSUITE_DIR)/.unpacked
- $(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
+$(LTP_TESTSUITE_DIR)/.compiled: $(LTP_TESTSUITE_DIR)/Makefile
+ $(MAKE1) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
-C $(LTP_TESTSUITE_DIR) all
- touch -c $(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01
+ touch $(LTP_TESTSUITE_DIR)/.compiled
-$(LTP_TESTSUITE_DIR)/testcases/bin/1K_file: $(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01
+$(LTP_TESTSUITE_DIR)/.installed: $(LTP_TESTSUITE_DIR)/.compiled
# Use fakeroot to pretend to do 'make install' as root
+ rm -f $(STAGING_DIR)/.fakeroot.ltp
$(STAGING_DIR)/usr/bin/fakeroot \
- -i $(STAGING_DIR)/fakeroot.env \
- -s $(STAGING_DIR)/fakeroot.env -- \
- $(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
+ -s $(STAGING_DIR)/.fakeroot.ltp -- \
+ $(MAKE1) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
-C $(LTP_TESTSUITE_DIR) install
- touch -c $(LTP_TESTSUITE_DIR)/testcases/bin/1K_file
+ touch $(LTP_TESTSUITE_DIR)/.installed
-ltp-testsuite: uclibc host-fakeroot $(LTP_TESTSUITE_DIR)/testcases/bin/1K_file
+ltp-testsuite: uclibc host-fakeroot $(LTP_TESTSUITE_DIR)/.installed
ltp-testsuite-clean:
$(MAKE) -C $(LTP_TESTSUITE_DIR) clean