summaryrefslogtreecommitdiffstats
path: root/package/ltp-testsuite
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2006-07-05 05:14:24 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2006-07-05 05:14:24 +0000
commit70a891e6939c79619e3b3e674a7f63ff88674ade (patch)
tree4b24b37207aa0ae9bff65a6fcd486c127814773c /package/ltp-testsuite
parent552c41e491f009656ac905301ab759f1df7fc9cf (diff)
downloadbuildroot-novena-70a891e6939c79619e3b3e674a7f63ff88674ade.tar.gz
buildroot-novena-70a891e6939c79619e3b3e674a7f63ff88674ade.zip
Add patch for building and running the Open POSIX Testsuite if NPTL has been selected with uClibc along with make directives. If someone has a cleaner way of handling things in the makefile, feel free to change it.
Diffstat (limited to 'package/ltp-testsuite')
-rw-r--r--package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch33
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk13
2 files changed, 45 insertions, 1 deletions
diff --git a/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch b/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch
new file mode 100644
index 000000000..ebb888cd9
--- /dev/null
+++ b/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch
@@ -0,0 +1,33 @@
+diff -ur ltp-full-20060615/testcases/Makefile ltp-full-20060615-patched/testcases/Makefile
+--- ltp-full-20060615/testcases/Makefile 2006-01-31 08:48:38.000000000 -0600
++++ ltp-full-20060615-patched/testcases/Makefile 2006-07-04 22:20:40.298850250 -0500
+@@ -1,4 +1,4 @@
+-SUBDIRS = `ls */Makefile | sed "s/Makefile//g" | grep -v open | grep -v pounder | grep -v DOTS`
++SUBDIRS = `ls */Makefile | sed "s/Makefile//g" | grep -v open_hpi | grep -v pounder | grep -v DOTS`
+ UCLINUX_SUBDIRS = kernel
+
+ all:
+diff -ur ltp-full-20060615/testcases/open_posix_testsuite/LDFLAGS ltp-full-20060615-patched/testcases/open_posix_testsuite/LDFLAGS
+--- ltp-full-20060615/testcases/open_posix_testsuite/LDFLAGS 2005-06-03 11:29:49.000000000 -0500
++++ ltp-full-20060615-patched/testcases/open_posix_testsuite/LDFLAGS 2006-07-04 22:21:34.322226500 -0500
+@@ -14,3 +14,5 @@
+ # allow for the NPTL-specific compilation (used in some test cases)
+ # Note: this sometimes require the package nptl-devel.*.rpm to be installed.
+ #-I /usr/include/nptl -L /usr/lib/nptl -D_XOPEN_SOURCE=600 -lpthread -lrt -lm
++
++-D_XOPEN_SOURCE=600 -lpthread -lrt -lm -D_GNU_SOURCE
+diff -ur ltp-full-20060615/testcases/open_posix_testsuite/Makefile ltp-full-20060615-patched/testcases/open_posix_testsuite/Makefile
+--- ltp-full-20060615/testcases/open_posix_testsuite/Makefile 2006-05-21 18:38:52.000000000 -0500
++++ ltp-full-20060615-patched/testcases/open_posix_testsuite/Makefile 2006-07-04 22:22:16.660872500 -0500
+@@ -45,7 +45,10 @@
+ TIMEOUT = $(top_builddir)/t0 $(TIMEOUT_VAL)
+
+
+-all: build-tests run-tests
++all: build-tests $(top_builddir)/t0
++
++install:
++ @echo " "
+
+ build-tests: $(BUILD_TESTS:.c=.test)
+ run-tests: $(RUN_TESTS:.test=.run-test)
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index 7b44764a8..b36894c4c 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -10,6 +10,17 @@ LTP_TESTSUITE_CAT:=zcat
LTP_TESTSUITE_ROOT:=$(TARGET_DIR)/root
LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-$(LTP_TESTSUITE_VERSION)
+#
+# We enable Open POSIX Testsuite if Native POSIX Threads Library (NPTL)
+# is selected. Otherwise, we filter out the patch for it.
+#
+LTP_PATCHES:=$(subst package/ltp-testsuite/,, \
+ $(wildcard package/ltp-testsuite/*.patch))
+ifneq ($(BR2_PTHREADS_NATIVE),y)
+LTP_PATCHES:=$(filter-out ltp-testsuite-enable-openposix-for-nptl.patch, \
+ $(LTP_PATCHES))
+endif
+
$(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
$(WGET) -P $(DL_DIR) $(LTP_TESTSUITE_SITE)/$(LTP_TESTSUITE_SOURCE)
@@ -18,7 +29,7 @@ ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_DIR)/Makefile: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(LTP_TESTSUITE_ROOT) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ ltp-testsuite\*.patch
+ toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ $(LTP_PATCHES)
touch -c $(LTP_TESTSUITE_DIR)/Makefile
$(LTP_TESTSUITE_DIR)/.compiled: $(LTP_TESTSUITE_DIR)/Makefile