summaryrefslogtreecommitdiffstats
path: root/package/ltp-testsuite
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-08-04 05:14:23 +0000
committerEric Andersen <andersen@codepoet.org>2005-08-04 05:14:23 +0000
commit1e218e33ebed5c3c434fcb3377d225d253d97128 (patch)
treee8d101797c2a3149436a19b4950ff6adc1eeea55 /package/ltp-testsuite
parent42c9321a15c2a98dd72cc09c7ef5900b5097c6eb (diff)
downloadbuildroot-novena-1e218e33ebed5c3c434fcb3377d225d253d97128.tar.gz
buildroot-novena-1e218e33ebed5c3c434fcb3377d225d253d97128.zip
Fix it up so ltp builds and installs itself properly so it is
100% ready to run on the target device.
Diffstat (limited to 'package/ltp-testsuite')
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk19
-rw-r--r--package/ltp-testsuite/ltp-testsuite.patch103
2 files changed, 100 insertions, 22 deletions
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index 626338c56..74707f294 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -3,10 +3,11 @@
# ltp-testsuite
#
#############################################################
-LTP_TESTSUITE_SOURCE:=ltp-full-20040506.tgz
+LTP_TESTSUITE_SOURCE:=ltp-full-20050707.tgz
LTP_TESTSUITE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ltp
LTP_TESTSUITE_CAT:=zcat
-LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20040506
+LTP_TESTSUITE_ROOT:=$(TARGET_DIR)/root
+LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-20050707
$(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
@@ -15,19 +16,23 @@ $(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
$(LTP_TESTSUITE_DIR)/.unpacked: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
- $(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ $(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(LTP_TESTSUITE_ROOT) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ ltp-testsuite\*.patch
touch $(LTP_TESTSUITE_DIR)/.unpacked
-$(LTP_TESTSUITE_DIR)/ltp-testsuite: $(LTP_TESTSUITE_DIR)/.unpacked
+$(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01: $(LTP_TESTSUITE_DIR)/.unpacked
$(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
- -C $(LTP_TESTSUITE_DIR)
+ -C $(LTP_TESTSUITE_DIR) all
+ touch -c $(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01
-$(TARGET_DIR)/usr/bin/ltp-testsuite: $(LTP_TESTSUITE_DIR)/ltp-testsuite
+$(LTP_TESTSUITE_DIR)/testcases/bin/1K_file: $(LTP_TESTSUITE_DIR)/testcases/kernel/syscalls/write/write01
+ # Use fakeroot to pretend to do 'make install' as root
+ $(STAGING_DIR)/usr/bin/fakeroot \
$(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
-C $(LTP_TESTSUITE_DIR) install
+ touch -c $(LTP_TESTSUITE_DIR)/testcases/bin/1K_file
-ltp-testsuite: uclibc $(TARGET_DIR)/usr/bin/ltp-testsuite
+ltp-testsuite: uclibc host-fakeroot $(LTP_TESTSUITE_DIR)/testcases/bin/1K_file
ltp-testsuite-clean:
$(MAKE) -C $(LTP_TESTSUITE_DIR) clean
diff --git a/package/ltp-testsuite/ltp-testsuite.patch b/package/ltp-testsuite/ltp-testsuite.patch
index baad6d6f5..5605ccd58 100644
--- a/package/ltp-testsuite/ltp-testsuite.patch
+++ b/package/ltp-testsuite/ltp-testsuite.patch
@@ -1,6 +1,67 @@
-diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20040506/testcases/kernel/syscalls/fmtmsg/Makefile
---- ltp-full-20040506.orig/testcases/kernel/syscalls/fmtmsg/Makefile 2003-03-04 09:15:27.000000000 -0700
-+++ ltp-full-20040506/testcases/kernel/syscalls/fmtmsg/Makefile 2004-05-12 14:03:56.000000000 -0600
+diff -urN ltp-full-20050707-dist/lib/tlibio.c ltp-full-20050707/lib/tlibio.c
+--- ltp-full-20050707-dist/lib/tlibio.c 2005-07-11 16:28:09.000000000 -0600
++++ ltp-full-20050707/lib/tlibio.c 2005-08-02 19:56:11.000000000 -0600
+@@ -101,9 +101,11 @@
+ #endif
+ #if defined(linux) || defined(__sun) || defined(__hpux) || defined(_AIX)
+ #ifndef UCLINUX
++#ifndef __UCLIBC__
+ #include <aio.h>
+ #endif
+ #endif
++#endif
+ #include <stdlib.h> /* atoi, abs */
+
+ #include "tlibio.h" /* defines LIO* marcos */
+diff -urN ltp-full-20050707-dist/testcases/kernel/io/disktest/Makefile ltp-full-20050707/testcases/kernel/io/disktest/Makefile
+--- ltp-full-20050707-dist/testcases/kernel/io/disktest/Makefile 2005-05-04 11:54:00.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/io/disktest/Makefile 2005-08-02 21:13:22.000000000 -0600
+@@ -150,8 +150,8 @@
+
+ VER=`grep VER_STR main.h | awk -F\" '{print $$2}'`
+ GBLHDRS=main.h globals.h defs.h
+-ALLHDRS=$(wildcard *.h)
+-SRCS=$(wildcard *.c)
++ALLHDRS=#$(wildcard *.h)
++SRCS=#$(wildcard *.c)
+ OBJS=$(SRCS:.c=.o)
+
+ CFLAGS= -g -Wall -O -D"LINUX" -D"_THREAD_SAFE" -D"_GNU_SOURCE" -D"_LARGE_FILES" -D"_LARGEFILE64_SOURCE" -D"_FILE_OFFSET_BITS=64"
+@@ -159,7 +159,7 @@
+ all: $(OBJS) disktest
+
+ disktest: $(OBJS) $(SRCS) $(ALLHDRS)
+- $(CC) $(CFLAGS) -lpthread -odisktest $(OBJS)
++ echo NEED TO $(CC) $(CFLAGS) -lpthread -odisktest $(OBJS)
+
+ main.o: main.c $(ALLHDRS)
+ sfunc.o: sfunc.c sfunc.h $(GBLHDRS)
+@@ -175,8 +175,8 @@
+ stats.o: stats.c stats.h $(GBLHDRS)
+
+ install: disktest
+- cp disktest $(bindir)
+- cp man1/disktest.1.gz $(mandir)/man1
++ echo NEED TO cp disktest $(bindir)
++ echo NEED TO cp man1/disktest.1.gz $(mandir)/man1
+
+ uninstall: disktest
+ rm -f $(bindir)/disktest
+diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20050707/testcases/kernel/syscalls/fmtmsg/Makefile
+--- ltp-full-20050707-dist/testcases/kernel/syscalls/fmtmsg/Makefile 2005-07-11 16:28:18.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/syscalls/fmtmsg/Makefile 2005-08-02 19:56:11.000000000 -0600
+@@ -26,7 +26,7 @@
+ LOADLIBES+= $(if $(UCLINUX),-lc)
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/getcontext01/Makefile ltp-full-20050707/testcases/kernel/syscalls/getcontext01/Makefile
+--- ltp-full-20050707-dist/testcases/kernel/syscalls/getcontext01/Makefile 2005-05-26 14:38:47.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/syscalls/getcontext01/Makefile 2005-08-02 19:56:11.000000000 -0600
@@ -24,7 +24,7 @@
LOADLIBES+= -L../../../../lib -lltp
@@ -10,11 +71,23 @@ diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/fmtmsg/Makefile ltp-f
all: $(TARGETS)
-diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/profil/Makefile ltp-full-20040506/testcases/kernel/syscalls/profil/Makefile
---- ltp-full-20040506.orig/testcases/kernel/syscalls/profil/Makefile 2003-03-04 09:16:26.000000000 -0700
-+++ ltp-full-20040506/testcases/kernel/syscalls/profil/Makefile 2004-05-12 14:03:56.000000000 -0600
-@@ -23,7 +23,7 @@
- LOADLIBES+= -L../../../../lib -lltp
+diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/profil/Makefile ltp-full-20050707/testcases/kernel/syscalls/profil/Makefile
+--- ltp-full-20050707-dist/testcases/kernel/syscalls/profil/Makefile 2005-07-11 16:28:53.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/syscalls/profil/Makefile 2005-08-02 19:56:11.000000000 -0600
+@@ -25,7 +25,7 @@
+ LOADLIBES+= $(if $(UCLINUX),-lc)
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/pselect/Makefile ltp-full-20050707/testcases/kernel/syscalls/pselect/Makefile
+--- ltp-full-20050707-dist/testcases/kernel/syscalls/pselect/Makefile 2005-05-26 09:35:58.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/syscalls/pselect/Makefile 2005-08-02 19:56:11.000000000 -0600
+@@ -24,7 +24,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
SRCS=$(wildcard *.c)
-TARGETS=$(patsubst %.c,%,$(SRCS))
@@ -22,21 +95,21 @@ diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/profil/Makefile ltp-f
all: $(TARGETS)
-diff -urN ltp-full-20040506.orig/testcases/kernel/syscalls/swapon/swapon02.c ltp-full-20040506/testcases/kernel/syscalls/swapon/swapon02.c
---- ltp-full-20040506.orig/testcases/kernel/syscalls/swapon/swapon02.c 2004-04-23 12:13:20.000000000 -0600
-+++ ltp-full-20040506/testcases/kernel/syscalls/swapon/swapon02.c 2004-05-12 23:02:50.000000000 -0600
-@@ -85,9 +85,7 @@
+diff -urN ltp-full-20050707-dist/testcases/kernel/syscalls/swapon/swapon02.c ltp-full-20050707/testcases/kernel/syscalls/swapon/swapon02.c
+--- ltp-full-20050707-dist/testcases/kernel/syscalls/swapon/swapon02.c 2005-07-11 16:29:08.000000000 -0600
++++ ltp-full-20050707/testcases/kernel/syscalls/swapon/swapon02.c 2005-08-02 19:56:38.000000000 -0600
+@@ -86,9 +86,7 @@
+ #include <sys/stat.h>
#include <sys/swap.h>
#include <asm/page.h>
- #include <asm/atomic.h>
-#ifdef OLDER_DISTRO_RELEASE
-#include <linux/swap.h>
-#endif
-+#define MAX_SWAPFILES 32
++#define MAX_SWAPFILES 32
#include <fcntl.h>
#include <pwd.h>
#include <string.h>
-@@ -96,10 +94,6 @@
+@@ -97,10 +95,6 @@
#include "test.h"
#include "usctest.h"