summaryrefslogtreecommitdiffstats
path: root/package/lsof
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-08-25 02:13:46 +0000
committerEric Andersen <andersen@codepoet.org>2006-08-25 02:13:46 +0000
commit6e17ffbaa201d046918336f5fedf74507c371927 (patch)
tree8d1ee763dea39f0ee439feff64319144223f8468 /package/lsof
parentcc352925b4a902518aaa2677fbf2a5151785d674 (diff)
downloadbuildroot-novena-6e17ffbaa201d046918336f5fedf74507c371927.tar.gz
buildroot-novena-6e17ffbaa201d046918336f5fedf74507c371927.zip
fixup lsof so it will apply patches, and compile when rpc is disabled
Diffstat (limited to 'package/lsof')
-rw-r--r--package/lsof/lsof-noportmap.patch18
-rw-r--r--package/lsof/lsof.mk1
2 files changed, 19 insertions, 0 deletions
diff --git a/package/lsof/lsof-noportmap.patch b/package/lsof/lsof-noportmap.patch
new file mode 100644
index 000000000..7101fd7d8
--- /dev/null
+++ b/package/lsof/lsof-noportmap.patch
@@ -0,0 +1,18 @@
+--- lsof_4.77/lsof_4.77_src/print.orig.c 2006-08-23 13:37:43.000000000 -0600
++++ lsof_4.77/lsof_4.77_src/print.c 2006-08-23 13:38:29.000000000 -0600
+@@ -148,6 +148,7 @@
+ static void
+ fill_portmap()
+ {
++#if !defined __UCLIBC__ || (defined __UCLIBC__ && defined __UCLIBC_HAS_RPC__)
+ char buf[128], *cp, *nm;
+ CLIENT *c;
+ int h, port, pr;
+@@ -266,6 +267,7 @@
+ Pth[pr][h] = pt;
+ }
+ clnt_destroy(c);
++#endif
+ }
+
+
diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk
index 6d1cef3ba..6c2966241 100644
--- a/package/lsof/lsof.mk
+++ b/package/lsof/lsof.mk
@@ -20,6 +20,7 @@ lsof-unpacked: $(LSOF_DIR)/.unpacked
$(LSOF_DIR)/.unpacked: $(DL_DIR)/$(LSOF_SOURCE)
$(LSOF_CAT) $(DL_DIR)/$(LSOF_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
(cd $(LSOF_DIR);tar xf lsof_4.77_src.tar;rm -f lsof_4.77_src.tar)
+ toolchain/patch-kernel.sh $(LSOF_DIR) package/lsof/ *.patch
touch $(LSOF_DIR)/.unpacked
$(LSOF_DIR)/.configured: $(LSOF_DIR)/.unpacked