summaryrefslogtreecommitdiffstats
path: root/package/lsof
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 15:49:00 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 15:49:00 +0100
commit50e0338bc86955bd982a43317a49175d16868dae (patch)
treeab8a1ef6f01108612c36dafb1252cf2a2444541a /package/lsof
parentfcde2191fa97ee51ccfd64cde900cc1344f09b2a (diff)
downloadbuildroot-novena-50e0338bc86955bd982a43317a49175d16868dae.tar.gz
buildroot-novena-50e0338bc86955bd982a43317a49175d16868dae.zip
lsof: fix build after gentargets conversion
With the gentargets conversion, the tarball is extracted directly in the source directory, so adjust paths to match. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lsof')
-rw-r--r--package/lsof/lsof.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk
index 05365dae3..167cb2041 100644
--- a/package/lsof/lsof.mk
+++ b/package/lsof/lsof.mk
@@ -18,16 +18,16 @@ endif
ifeq ($(BR2_USE_WCHAR),)
define LSOF_CONFIGURE_WCHAR_FIXUPS
$(SED) 's,^#define[[:space:]]*HASWIDECHAR.*,#undef HASWIDECHAR,' \
- $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+ $(@D)/machine.h
$(SED) 's,^#define[[:space:]]*WIDECHARINCL.*,,' \
- $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+ $(@D)/machine.h
endef
endif
ifeq ($(BR2_ENABLE_LOCALE),)
define LSOF_CONFIGURE_LOCALE_FIXUPS
$(SED) 's,^#define[[:space:]]*HASSETLOCALE.*,#undef HASSETLOCALE,' \
- $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+ $(@D)/machine.h
endef
endif
@@ -60,7 +60,7 @@ define LSOF_UNINSTALL_TARGET_CMDS
endef
define LSOF_CLEAN_CMDS
- -$(MAKE) -C $(@D)/lsof_$(LSOF_VERSION)_src clean
+ -$(MAKE) -C $(@D) clean
endef
$(eval $(call GENTARGETS,package,lsof))