summaryrefslogtreecommitdiffstats
path: root/package/lsof/lsof.mk
diff options
context:
space:
mode:
authorAndy Gibbs <andyg1001@hotmail.co.uk>2010-11-03 15:09:24 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-04 17:15:18 +0100
commit44b170e104a6acc527fbcaee19ce63e8e51ea279 (patch)
tree56f8c325c286dc01433d7588c02336c5cc7b56cf /package/lsof/lsof.mk
parent382ade52a5275c1e84882afc46f2aa2e8259bc19 (diff)
downloadbuildroot-novena-44b170e104a6acc527fbcaee19ce63e8e51ea279.tar.gz
buildroot-novena-44b170e104a6acc527fbcaee19ce63e8e51ea279.zip
lsof: stop overriding CFLAGS in build
Closes #2767 lsof compile breaks if CFLAGS overridden in 'make' command line which is the case since buildroot-2010.08. lsof has a partial fix for this already in the form of the 'LSOF_CFLAGS_OVERRIDE=1' configure option; however this only fixes the problem in the generation of the Makefile for liblsof. This patch does two things: it extends the 'LSOF_CFLAGS_OVERRIDE=1' configure option to also cover the main Makefile; it also patches lsof.mk to make use of the LSOF_CFLAGS_OVERRIDE option. Signed-off-by: Andy Gibbs <andyg1001@hotmail.co.uk> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lsof/lsof.mk')
-rw-r--r--package/lsof/lsof.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk
index 8deff15f1..837a88c2e 100644
--- a/package/lsof/lsof.mk
+++ b/package/lsof/lsof.mk
@@ -34,7 +34,7 @@ $(LSOF_DIR)/.unpacked: $(DL_DIR)/$(LSOF_SOURCE)
touch $(LSOF_DIR)/.unpacked
$(LSOF_DIR)/.configured: $(LSOF_DIR)/.unpacked
- (cd $(LSOF_DIR)/lsof_$(LSOF_VERSION)_src; echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS) $(BR2_LSOF_CFLAGS)" LSOF_INCLUDE="$(LSOF_INCLUDE)" ./Configure linux)
+ (cd $(LSOF_DIR)/lsof_$(LSOF_VERSION)_src; echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS) $(BR2_LSOF_CFLAGS)" LSOF_INCLUDE="$(LSOF_INCLUDE)" LSOF_CFLAGS_OVERRIDE=1 ./Configure linux)
touch $(LSOF_DIR)/.configured
$(LSOF_DIR)/lsof_$(LSOF_VERSION)_src/$(LSOF_BINARY): $(LSOF_DIR)/.configured