summaryrefslogtreecommitdiffstats
path: root/package/lrzsz
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/lrzsz
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
downloadbuildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.tar.gz
buildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.zip
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/lrzsz')
-rw-r--r--package/lrzsz/lrzsz.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/package/lrzsz/lrzsz.mk b/package/lrzsz/lrzsz.mk
new file mode 100644
index 000000000..222d64a71
--- /dev/null
+++ b/package/lrzsz/lrzsz.mk
@@ -0,0 +1,76 @@
+#############################################################
+#
+# lrzsz (provides zmodem)
+#
+#############################################################
+# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+LRZSZ_SITE:=http://www.ohse.de/uwe/releases
+LRZSZ_SOURCE:=lrzsz-0.12.20.tar.gz
+LRZSZ_DIR:=$(BUILD_DIR)/lrzsz-0.12.20
+
+$(DL_DIR)/$(LRZSZ_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LRZSZ_SITE)/$(LRZSZ_SOURCE)
+
+lrzsz-source: $(DL_DIR)/$(LRZSZ_SOURCE)
+
+$(LRZSZ_DIR)/.unpacked: $(DL_DIR)/$(LRZSZ_SOURCE)
+ zcat $(DL_DIR)/$(LRZSZ_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(LRZSZ_DIR)/.unpacked
+
+$(LRZSZ_DIR)/.configured: $(LRZSZ_DIR)/.unpacked
+ (cd $(LRZSZ_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/tmp \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $(DISABLE_NLS) \
+ --disable-timesync \
+ );
+ $(SED) "s/-lnsl//;" $(LRZSZ_DIR)/src/Makefile
+ $(SED) "s~\(#define ENABLE_SYSLOG.*\)~/* \1 */~;" $(LRZSZ_DIR)/config.h
+ touch $(LRZSZ_DIR)/.configured
+
+$(LRZSZ_DIR)/src/lrz: $(LRZSZ_DIR)/.configured
+ $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" prefix="$(TARGET_DIR)" -C $(LRZSZ_DIR)
+ $(STRIP) $(LRZSZ_DIR)/src/lrz $(LRZSZ_DIR)/src/lsz
+
+$(TARGET_DIR)/usr/bin/rz: $(LRZSZ_DIR)/src/lrz
+ cp $(LRZSZ_DIR)/src/lrz $(TARGET_DIR)/usr/bin/rz
+ cp $(LRZSZ_DIR)/src/lsz $(TARGET_DIR)/usr/bin/sz
+
+lrzsz: uclibc $(TARGET_DIR)/usr/bin/rz
+
+lrzsz-clean:
+ rm -f $(TARGET_DIR)/usr/bin/rz
+ -$(MAKE) -C $(LRZSZ_DIR) clean
+
+lrzsz-dirclean:
+ rm -rf $(LRZSZ_DIR)