summaryrefslogtreecommitdiffstats
path: root/package/lockfile-progs
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /package/lockfile-progs
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
downloadbuildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.tar.gz
buildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.zip
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'package/lockfile-progs')
-rw-r--r--package/lockfile-progs/lockfile-progs.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/lockfile-progs/lockfile-progs.mk b/package/lockfile-progs/lockfile-progs.mk
index c20e48bc3..2fdaa4b8d 100644
--- a/package/lockfile-progs/lockfile-progs.mk
+++ b/package/lockfile-progs/lockfile-progs.mk
@@ -20,8 +20,7 @@ $(LOCKFILE_PROGS_DIR)/.unpacked: $(DL_DIR)/$(LOCKFILE_PROGS_SOURCE)
touch $(LOCKFILE_PROGS_DIR)/.unpacked
$(TARGET_DIR)/$(LOCKFILE_PROGS_BINARY): $(LOCKFILE_PROGS_DIR)/.unpacked
- $(MAKE) CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" -C $(LOCKFILE_PROGS_DIR)
+ $(MAKE) CC="$(TARGET_CC) $(TARGET_CFLAGS)" -C $(LOCKFILE_PROGS_DIR)
cp -a $(LOCKFILE_PROGS_DIR)/bin/lockfile* $(TARGET_DIR)/usr/bin
$(STRIP) --strip-unneeded $(TARGET_DIR)/$(LOCKFILE_PROGS_BINARY)