summaryrefslogtreecommitdiffstats
path: root/package/lite
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-26 14:52:17 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-26 14:52:17 +0000
commitc30bb46320213eaa6c95ad991512b03e7fc38c4b (patch)
tree0cef025f5300e42b67838dcff82b7ff63f2e1653 /package/lite
parent6b76f0608a3c46f66b1d223cf4fa75f009e1c41f (diff)
downloadbuildroot-novena-c30bb46320213eaa6c95ad991512b03e7fc38c4b.tar.gz
buildroot-novena-c30bb46320213eaa6c95ad991512b03e7fc38c4b.zip
Adds support for building LiTE - see DirectFB.org
Will close bug 0003974 Daniel Laird
Diffstat (limited to 'package/lite')
-rw-r--r--package/lite/Config.in12
-rw-r--r--package/lite/lite.mk25
-rw-r--r--package/lite/no_tests.patch14
3 files changed, 51 insertions, 0 deletions
diff --git a/package/lite/Config.in b/package/lite/Config.in
new file mode 100644
index 000000000..8840fe47b
--- /dev/null
+++ b/package/lite/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LITE
+ bool "LiTE (toolbox engine)"
+ depends on BR2_PACKAGE_DIRECTFB
+ help
+ LiTE stands for LiTE is a Toolbox Engine.
+ Its role is to facilitate the functions of DirectFB so that a
+ toolbox could be written on top of DirectFB with less effort.
+ As such LiTE has abstractions for the underlying graphics and
+ event systems.
+
+ See http://www.directfb.org/wiki/index.php/LiTE:Architecture
+
diff --git a/package/lite/lite.mk b/package/lite/lite.mk
new file mode 100644
index 000000000..ad1963278
--- /dev/null
+++ b/package/lite/lite.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# LiTE
+#
+#############################################################
+LITE_VERSION:=0.8.9
+LITE_SOURCE:=LiTE-$(LITE_VERSION).tar.gz
+LITE_SITE:=http://www.directfb.org/downloads/Libs
+LITE_AUTORECONF = NO
+LITE_INSTALL_STAGING = YES
+LITE_INSTALL_TARGET = YES
+LITE_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install
+LITE_CONF_ENV = DFB_CFLAGS=-I$(STAGING_DIR)/usr/include/directfb
+LITE_CONF_OPT =
+LITE_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,lite))
+
+$(LITE_HOOK_POST_INSTALL):
+ $(INSTALL) -d $(TARGET_DIR)/usr/share/LiTE/examples/
+ $(INSTALL) -d $(TARGET_DIR)/usr/share/fonts/truetype
+ $(INSTALL) -m0644 $(LITE_DIR)/data/*.png $(TARGET_DIR)/usr/share/LiTE/
+ $(INSTALL) -m0644 $(LITE_DIR)/examples/*.png $(TARGET_DIR)/usr/share/LiTE/examples/
+ $(INSTALL) -m0644 $(LITE_DIR)/fonts/*.ttf $(TARGET_DIR)/usr/share/fonts/truetype/
+ touch $@ \ No newline at end of file
diff --git a/package/lite/no_tests.patch b/package/lite/no_tests.patch
new file mode 100644
index 000000000..4ca39137b
--- /dev/null
+++ b/package/lite/no_tests.patch
@@ -0,0 +1,14 @@
+--- package/lite/no-examples-no-tests.patch (revision 0)
++++ package/lite/no-examples-no-tests.patch (revision 0)
+@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2008-07-07 13:07:12.000000000 +0200
++++ Makefile.in 2008-07-07 13:07:05.000000000 +0200
+@@ -202,7 +202,7 @@
+ target_vendor = @target_vendor@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = data fonts lite leck examples tests
++SUBDIRS = data fonts lite leck examples
+ EXTRA_DIST = TODO lite.pc.in leck.pc.in
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = lite.pc leck.pc