summaryrefslogtreecommitdiffstats
path: root/package/linphone
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-06-03 21:25:00 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-04 09:12:45 +0200
commit96f41055068e54e734edc99c88ec46aa40d8ced5 (patch)
treeea61980b712d1d5a8a00fb810a1d5105c907d867 /package/linphone
parentfdf093b7cef81cc9cbf8bdab3a7e2d88a02d611d (diff)
downloadbuildroot-novena-96f41055068e54e734edc99c88ec46aa40d8ced5.tar.gz
buildroot-novena-96f41055068e54e734edc99c88ec46aa40d8ced5.zip
linphone: use external ortp/mediastreamer libraries
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/linphone')
-rw-r--r--package/linphone/Config.in6
-rw-r--r--package/linphone/linphone.mk8
2 files changed, 12 insertions, 2 deletions
diff --git a/package/linphone/Config.in b/package/linphone/Config.in
index 31c28d8b4..1a6cfdb00 100644
--- a/package/linphone/Config.in
+++ b/package/linphone/Config.in
@@ -2,6 +2,9 @@ config BR2_PACKAGE_LINPHONE
bool "linphone"
select BR2_PACKAGE_LIBEXOSIP2
select BR2_PACKAGE_SPEEX
+ select BR2_PACKAGE_ORTP
+ select BR2_PACKAGE_MEDIASTREAMER
+ depends on BR2_INSTALL_LIBSTDCPP # mediastreamer
help
Linphone is an internet phone or Voice Over IP phone (VoIP).
@@ -19,3 +22,6 @@ config BR2_PACKAGE_LINPHONE
client, linphonec, and video support is not enabled.
http://www.linphone.org/
+
+comment "linphone requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/linphone/linphone.mk b/package/linphone/linphone.mk
index 6ba6b5333..b34fbf741 100644
--- a/package/linphone/linphone.mk
+++ b/package/linphone/linphone.mk
@@ -6,7 +6,11 @@
LINPHONE_VERSION = 3.5.2
LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/3.5.x/sources/
-LINPHONE_CONF_OPT = --disable-video --disable-gtk_ui
-LINPHONE_DEPENDENCIES = libeXosip2 speex
+LINPHONE_CONF_OPT = \
+ --disable-gtk_ui \
+ --enable-external-ortp \
+ --enable-external-mediastreamer
+
+LINPHONE_DEPENDENCIES = host-pkg-config ortp mediastreamer libeXosip2 speex
$(eval $(call AUTOTARGETS))