summaryrefslogtreecommitdiffstats
path: root/package/linenoise
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2012-12-05 08:06:51 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-05 10:56:00 -0800
commitd87847203f3b1b6af51515978563f0dee737b6fd (patch)
treef3fdd6cd43431ba79719eb32347e368d74871b65 /package/linenoise
parentac3ee237d96731b869eeca435e1b8351aacd245b (diff)
downloadbuildroot-novena-d87847203f3b1b6af51515978563f0dee737b6fd.tar.gz
buildroot-novena-d87847203f3b1b6af51515978563f0dee737b6fd.zip
linenoise: new package
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/linenoise')
-rw-r--r--package/linenoise/Config.in6
-rw-r--r--package/linenoise/linenoise-get-columns.patch20
-rw-r--r--package/linenoise/linenoise.mk45
3 files changed, 71 insertions, 0 deletions
diff --git a/package/linenoise/Config.in b/package/linenoise/Config.in
new file mode 100644
index 000000000..8e4ab91da
--- /dev/null
+++ b/package/linenoise/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LINENOISE
+ bool "linenoise"
+ help
+ A small self-contained alternative to readline and libedit
+
+ https://github.com/antirez/linenoise
diff --git a/package/linenoise/linenoise-get-columns.patch b/package/linenoise/linenoise-get-columns.patch
new file mode 100644
index 000000000..4fb9e4085
--- /dev/null
+++ b/package/linenoise/linenoise-get-columns.patch
@@ -0,0 +1,20 @@
+returns the default value (80) when a real value is not available
+(0 is not an acceptable value for COLUMNS, the width of the screen).
+
+see pull request on upstream : http://github.com/antirez/linenoise/pull/31
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/linenoise.c
+===================================================================
+--- a/linenoise.c
++++ b/linenoise.c
+@@ -182,7 +182,7 @@
+ static int getColumns(void) {
+ struct winsize ws;
+
+- if (ioctl(1, TIOCGWINSZ, &ws) == -1) return 80;
++ if (ioctl(1, TIOCGWINSZ, &ws) == -1 || ws.ws_col == 0) return 80;
+ return ws.ws_col;
+ }
+
diff --git a/package/linenoise/linenoise.mk b/package/linenoise/linenoise.mk
new file mode 100644
index 000000000..343a10756
--- /dev/null
+++ b/package/linenoise/linenoise.mk
@@ -0,0 +1,45 @@
+#############################################################
+#
+# linenoise
+#
+#############################################################
+LINENOISE_VERSION = g8c9b481
+LINENOISE_SITE = http://github.com/antirez/linenoise/tarball/master
+LINENOISE_LICENSE = BSD-2c
+LINENOISE_INSTALL_STAGING = YES
+
+define LINENOISE_BUILD_CMDS
+ cd $(@D); $(TARGET_CC) $(TARGET_CFLAGS) -c linenoise.c
+ cd $(@D); $(TARGET_AR) rcu liblinenoise.a linenoise.o
+ cd $(@D); $(TARGET_CC) $(TARGET_LDFLAGS) -o linenoise_example example.c -L. -llinenoise
+endef
+
+define LINENOISE_INSTALL_STAGING_CMDS
+ $(INSTALL) -m 644 -D $(@D)/linenoise.h $(STAGING_DIR)/usr/include/linenoise.h
+ $(INSTALL) -m 644 -D $(@D)/liblinenoise.a $(STAGING_DIR)/usr/lib/liblinenoise.a
+ $(INSTALL) -m 755 -D $(@D)/linenoise_example $(STAGING_DIR)/usr/bin/linenoise_example
+endef
+
+define LINENOISE_UNINSTALL_STAGING_CMDS
+ rm -f $(STAGING_DIR)/usr/include/linenoise.h
+ rm -f $(STAGING_DIR)/usr/lib/liblinenoise.a
+ rm -f $(STAGING_DIR)/usr/bin/linenoise_example
+endef
+
+define LINENOISE_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 644 -D $(@D)/linenoise.h $(TARGET_DIR)/usr/include/linenoise.h
+ $(INSTALL) -m 644 -D $(@D)/liblinenoise.a $(TARGET_DIR)/usr/lib/liblinenoise.a
+ $(INSTALL) -m 755 -D $(@D)/linenoise_example $(TARGET_DIR)/usr/bin/linenoise_example
+endef
+
+define LINENOISE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/include/linenoise.h
+ rm -f $(TARGET_DIR)/usr/lib/liblinenoise.a
+ rm -f $(TARGET_DIR)/usr/bin/linenoise_example
+endef
+
+define LINENOISE_CLEAN_CMDS
+ rm -f $(@D)/*.o $(@D)/*.a $(@D)/linenoise_example
+endef
+
+$(eval $(generic-package))