summaryrefslogtreecommitdiffstats
path: root/package/lighttpd
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2011-03-03 14:53:30 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-01 23:02:35 +0200
commit99df35d9a5246751a4a751f4b4b5c5cdbc78bc6a (patch)
treebf7c01a85b60e4c1e8b867db738e92ade996e4d1 /package/lighttpd
parent94ed034cf2f669d1af37f8f08e70e123519e4c62 (diff)
downloadbuildroot-novena-99df35d9a5246751a4a751f4b4b5c5cdbc78bc6a.tar.gz
buildroot-novena-99df35d9a5246751a4a751f4b4b5c5cdbc78bc6a.zip
buildroot: Add webdav support to lighttpd.
[Peter: needs host-pkg-config] Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lighttpd')
-rw-r--r--package/lighttpd/Config.in8
-rw-r--r--package/lighttpd/lighttpd.mk9
2 files changed, 16 insertions, 1 deletions
diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
index b56d66b4c..49877e418 100644
--- a/package/lighttpd/Config.in
+++ b/package/lighttpd/Config.in
@@ -42,5 +42,13 @@ config BR2_PACKAGE_LIGHTTPD_PCRE
help
Enable PCRE support. Needed to support mod_rewrite
+config BR2_PACKAGE_LIGHTTPD_WEBDAV
+ bool "webdav"
+ depends on BR2_PACKAGE_LIGHTTPD
+ select BR2_PACKAGE_LIBXML2
+ select BR2_PACKAGE_SQLITE
+ help
+ Enable webdav support. Needed to support mod_webdav
+
endmenu
endif
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 67cd27241..590180153 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -6,7 +6,7 @@
LIGHTTPD_VERSION = 1.4.28
LIGHTTPD_SITE = http://download.lighttpd.net/lighttpd/releases-1.4.x
-
+LIGHTTPD_DEPENDENCIES = host-pkg-config
LIGHTTPD_CONF_OPT = \
--libdir=/usr/lib/lighttpd \
--libexecdir=/usr/lib \
@@ -43,6 +43,13 @@ else
LIGHTTPD_CONF_OPT += --without-pcre
endif
+ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
+LIGHTTPD_DEPENDENCIES += libxml2 sqlite
+LIGHTTPD_CONF_OPT += --with-webdav-props --with-webdav-locks
+else
+LIGHTTPD_CONF_OPT += ---without-webdav-props --without-webdav-locks
+endif
+
define LIGHTTPD_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/lighttpd
rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel