summaryrefslogtreecommitdiffstats
path: root/package/lighttpd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:24:17 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:51 +0200
commit7d6e7bcc26d84846838a493d3c10e254ae824552 (patch)
tree240688724f36be6f7942db9db813dd63a4e547d7 /package/lighttpd
parent2d30d8f4ebd4a8f4a259e214a96aab0f7124501f (diff)
downloadbuildroot-novena-7d6e7bcc26d84846838a493d3c10e254ae824552.tar.gz
buildroot-novena-7d6e7bcc26d84846838a493d3c10e254ae824552.zip
lighttpd: use correct step override method
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lighttpd')
-rw-r--r--package/lighttpd/lighttpd.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 3ac1f07ad..e6f913cbc 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -44,11 +44,10 @@ else
LIGHTTPD_CONF_OPT += --without-pcre
endif
-$(eval $(call AUTOTARGETS,package,lighttpd))
-
-$(LIGHTTPD_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define LIGHTTPD_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/lighttpd
rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel
rm -rf $(TARGET_DIR)/usr/lib/lighttpd
- rm -f $(LIGHTTPD_TARGET_INSTALL_TARGET) $(LIGHTTPD_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,lighttpd))