summaryrefslogtreecommitdiffstats
path: root/package/libxslt
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-20 18:12:34 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-20 19:31:04 +0100
commit73c937229bff334c9e4b88b7cc094ff4e576cdf4 (patch)
treeb104ed0ec82d08cfed834a6ce86712a21662332a /package/libxslt
parente81149c54301f88ae64bd85caa6d0f29e879d064 (diff)
downloadbuildroot-novena-73c937229bff334c9e4b88b7cc094ff4e576cdf4.tar.gz
buildroot-novena-73c937229bff334c9e4b88b7cc094ff4e576cdf4.zip
libxslt: enable compilation on host
Compiling libxcb (from the X.org stack) requires xsltproc on the host, which is part of libxslt. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libxslt')
-rw-r--r--package/libxslt/libxslt.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk
index 03c113103..4bf61b54c 100644
--- a/package/libxslt/libxslt.mk
+++ b/package/libxslt/libxslt.mk
@@ -25,7 +25,15 @@ LIBXSLT_CONF_OPT = --with-gnu-ld --enable-shared \
LIBXSLT_DEPENDENCIES = libxml2 $(LIBXSLT_DEPENDENCIES_EXTRA)
+HOST_LIBXSLT_CONF_OPT = --enable-shared \
+ --without-debugging \
+ --without-python \
+ --without-threads
+
+HOST_LIBXSLT_DEPENDENCIES = host-libxml2
+
$(eval $(call AUTOTARGETS,package,libxslt))
+$(eval $(call AUTOTARGETS,package,libxslt,host))
$(LIBXSLT_HOOK_POST_INSTALL):
$(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xslt-config