summaryrefslogtreecommitdiffstats
path: root/package/libxslt
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 17:12:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:24:58 +0200
commit1c8e89f4ce9a13fb1050426e3f31a3e23598b125 (patch)
treea188c12856a3b8f3fdf3e0793f4a3cad51494ff0 /package/libxslt
parent90710e0c228c29a9e871db331dd84524c9e510ea (diff)
downloadbuildroot-novena-1c8e89f4ce9a13fb1050426e3f31a3e23598b125.tar.gz
buildroot-novena-1c8e89f4ce9a13fb1050426e3f31a3e23598b125.zip
libxslt: convert old-style hook to new-style hook
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libxslt')
-rw-r--r--package/libxslt/libxslt.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk
index e77663df2..5437e2988 100644
--- a/package/libxslt/libxslt.mk
+++ b/package/libxslt/libxslt.mk
@@ -32,12 +32,13 @@ HOST_LIBXSLT_CONF_OPT = --enable-shared \
HOST_LIBXSLT_DEPENDENCIES = host-libxml2
-$(eval $(call AUTOTARGETS,package,libxslt))
-$(eval $(call AUTOTARGETS,package,libxslt,host))
-
-$(LIBXSLT_HOOK_POST_INSTALL):
+define LIBXSLT_XSLT_CONFIG_FIXUP
$(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xslt-config
$(SED) "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xslt-config
$(SED) "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include\',g" $(STAGING_DIR)/usr/bin/xslt-config
- touch $@
+endef
+LIBXSLT_POST_INSTALL_STAGING_HOOKS += LIBXSLT_XSLT_CONFIG_FIXUP
+
+$(eval $(call AUTOTARGETS,package,libxslt))
+$(eval $(call AUTOTARGETS,package,libxslt,host))