summaryrefslogtreecommitdiffstats
path: root/package/libxml-parser-perl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 13:15:22 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:33:44 +0100
commitc13460f769bb4fe88e23a8070b00bab46005cbf2 (patch)
treef153630fe60f9f779f289e1b9090b4b5f3e2b2b5 /package/libxml-parser-perl
parentce1f459b8bb0654a717124a1284b7204616ca199 (diff)
downloadbuildroot-novena-c13460f769bb4fe88e23a8070b00bab46005cbf2.tar.gz
buildroot-novena-c13460f769bb4fe88e23a8070b00bab46005cbf2.zip
libxml-parser-perl: new package
This Perl module is needed to build intltool, which in turn is needed to build several of our packages. We assume that Perl is installed on the host. Only the host variant of this package has been tested and is used. The code for the target variant (what to do at the configure, build and install steps) isn't implemented, but the GENTARGETS call for the target is mandatory, due to limitations of the Makefile.package.in infrastructure (if one wants the host package to be implemented, then the target package *must* exist). This limitation will be removed after 2010.02. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libxml-parser-perl')
-rw-r--r--package/libxml-parser-perl/Config.in8
-rw-r--r--package/libxml-parser-perl/libxml-parser-perl.mk34
2 files changed, 42 insertions, 0 deletions
diff --git a/package/libxml-parser-perl/Config.in b/package/libxml-parser-perl/Config.in
new file mode 100644
index 000000000..d20a401d8
--- /dev/null
+++ b/package/libxml-parser-perl/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBXML_PARSER_PERL
+ bool "libxml-parser-perl"
+ select BR2_PACKAGE_EXPAT
+ help
+ The Perl XML::Parser module.
+
+ http://www.cpan.org/modules/by-module/XML/
+
diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk b/package/libxml-parser-perl/libxml-parser-perl.mk
new file mode 100644
index 000000000..52d89d581
--- /dev/null
+++ b/package/libxml-parser-perl/libxml-parser-perl.mk
@@ -0,0 +1,34 @@
+#############################################################
+#
+# libxml-parser-perl
+#
+#############################################################
+LIBXML_PARSER_PERL_VERSION:=2.36
+LIBXML_PARSER_PERL_SOURCE:=XML-Parser-$(LIBXML_PARSER_PERL_VERSION).tar.gz
+LIBXML_PARSER_PERL_SITE:=http://www.cpan.org/modules/by-module/XML/
+
+LIBXML_PARSER_PERL_DEPENDENCIES = expat
+HOST_LIBXML_PARSER_PERL_DEPENDENCIES = host-expat
+
+define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
+ (cd $(@D) ; \
+ perl Makefile.PL \
+ PREFIX=$(HOST_DIR)/usr \
+ EXPATLIBPATH=$(HOST_DIR)/usr/lib \
+ EXPATINCPATH=$(HOST_DIR)/usr/include \
+ INSTALLDIRS=site \
+ INSTALLSITELIB=$(HOST_DIR)/usr/lib/perl \
+ )
+endef
+
+define HOST_LIBXML_PARSER_PERL_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_LIBXML_PARSER_PERL_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+endef
+
+$(eval $(call GENTARGETS,package,libxml-parser-perl))
+$(eval $(call GENTARGETS,package,libxml-parser-perl,host))
+