summaryrefslogtreecommitdiffstats
path: root/package/libvorbis
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-17 12:30:31 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-17 12:30:31 +0000
commite4c6340a949f64e6fc0294a1e41cf05dbaa82df9 (patch)
tree12a7f94b8461feec5eb1ad87481ddb06eb6834f8 /package/libvorbis
parentb14ff970126831720990961f0a7e2fd5f019365d (diff)
downloadbuildroot-novena-e4c6340a949f64e6fc0294a1e41cf05dbaa82df9.tar.gz
buildroot-novena-e4c6340a949f64e6fc0294a1e41cf05dbaa82df9.zip
- cleanup and fixes (Cristian Ionescu-Idbohrn)
Diffstat (limited to 'package/libvorbis')
-rw-r--r--package/libvorbis/Config.in4
-rw-r--r--package/libvorbis/libvorbis.mk26
2 files changed, 16 insertions, 14 deletions
diff --git a/package/libvorbis/Config.in b/package/libvorbis/Config.in
index 70ae79ba3..b84c45843 100644
--- a/package/libvorbis/Config.in
+++ b/package/libvorbis/Config.in
@@ -3,9 +3,9 @@ config BR2_PACKAGE_LIBVORBIS
default n
help
Library for the Vorbis open source audio decoder
- Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
+ Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
general-purpose compressed audio format for mid to high quality
- (8kHz-48.0kHz, 16+ bit, polyphonic) audio and music at fixed and
+ (8kHz-48.0kHz, 16+ bit, polyphonic) audio and music at fixed and
variable bitrates from 16 to 128 kbps/channel.
This places Vorbis in the same competitive class as audio representations
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
index 55333f608..c244ad74b 100644
--- a/package/libvorbis/libvorbis.mk
+++ b/package/libvorbis/libvorbis.mk
@@ -78,13 +78,13 @@ TREMOR_SOURCE:=$(TREMOR_NAME).tar.bz2
$(DL_DIR)/$(TREMOR_SOURCE):
- (cd $(BUILD_DIR) ; \
- svn co $(TREMOR_TRUNK) ; \
- mv -af Tremor $(TREMOR_NAME) ; \
- tar -cvf $(TREMOR_NAME).tar $(TREMOR_DIR); \
- bzip2 $(TREMOR_NAME).tar ; \
- rm -fr $(TREMOR_DIR) ; \
- mv $(TREMOR_NAME).tar.bz2 $(DL_DIR)/$(TREMOR_SOURCE) ; \
+ (cd $(BUILD_DIR); \
+ svn co $(TREMOR_TRUNK); \
+ mv -af Tremor $(TREMOR_NAME); \
+ tar -cvf $(TREMOR_NAME).tar $(TREMOR_DIR); \
+ bzip2 $(TREMOR_NAME).tar; \
+ rm -fr $(TREMOR_DIR); \
+ mv $(TREMOR_NAME).tar.bz2 $(DL_DIR)/$(TREMOR_SOURCE); \
)
$(TREMOR_DIR)/.source: $(DL_DIR)/$(TREMOR_SOURCE)
@@ -92,11 +92,13 @@ $(TREMOR_DIR)/.source: $(DL_DIR)/$(TREMOR_SOURCE)
touch $@
$(TREMOR_DIR)/.configured: $(TREMOR_DIR)/.source
- (cd $(TREMOR_DIR); rm -rf config.cache ; \
+ (cd $(TREMOR_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_ARGS) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- PKG_CONFIG_PATH="$(STAGING_DIR)/lib/pkconfig:$(STAGING_DIR)/usr/lib/pkgconfig" PKG_CONFIG="$(STAGING_DIR)/usr/bin/pkg-config" PKG_CONFIG_SYSROOT=$(STAGING_DIR) \
+ PKG_CONFIG_PATH="$(STAGING_DIR)/lib/pkconfig:$(STAGING_DIR)/usr/lib/pkgconfig" \
+ PKG_CONFIG="$(STAGING_DIR)/usr/bin/pkg-config" \
+ PKG_CONFIG_SYSROOT=$(STAGING_DIR) \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -107,7 +109,7 @@ $(TREMOR_DIR)/.configured: $(TREMOR_DIR)/.source
--enable-static \
--disable-oggtest \
$(DISABLE_NLS) \
- );
+ )
touch $@
$(TREMOR_DIR)/.libs: $(TREMOR_DIR)/.configured
@@ -124,7 +126,8 @@ $(TARGET_DIR)/usr/lib/tremor.a: $(TARGET_DIR)/usr/lib/tremor.so
tremor-header: $(TARGET_DIR)/usr/lib/tremor.a
mkdir -p $(TARGET_DIR)/usr/include/vorbis
- cp -dpf $(TREMOR_DIR)/include/vorbis/*.h $(TARGET_DIR)/usr/include/vorbis
+ cp -dpf $(TREMOR_DIR)/include/vorbis/*.h \
+ $(TARGET_DIR)/usr/include/vorbis
tremor: uclibc pkgconfig $(TARGET_DIR)/usr/lib/tremor.so
@@ -154,4 +157,3 @@ endif
ifeq ($(strip $(BR2_PACKAGE_LIBVORBIS_HEADERS)),y)
TARGETS+=libvorbis-header
endif
-