summaryrefslogtreecommitdiffstats
path: root/package/libvorbis
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-03 08:14:54 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-03 08:14:54 +0000
commit558f0a30730b35d4901a047885231369e7c919a7 (patch)
treede699a592ff82acf9d14354efa40bc389e5bddbf /package/libvorbis
parent5800bd037d66c3d2365af181d9163fcbd9b08677 (diff)
downloadbuildroot-novena-558f0a30730b35d4901a047885231369e7c919a7.tar.gz
buildroot-novena-558f0a30730b35d4901a047885231369e7c919a7.zip
Cleanup libvorbis, install in STAGING_DIR, courtesy Conrad Parker
Diffstat (limited to 'package/libvorbis')
-rw-r--r--package/libvorbis/libvorbis.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
index 3e496d938..6e72ad586 100644
--- a/package/libvorbis/libvorbis.mk
+++ b/package/libvorbis/libvorbis.mk
@@ -40,12 +40,15 @@ $(LIBVORBIS_DIR)/.configured: $(LIBVORBIS_DIR)/.source
touch $@
$(LIBVORBIS_DIR)/.libs: $(LIBVORBIS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(LIBVORBIS_DIR)
+ $(MAKE) -C $(@D)
touch $@
-$(TARGET_DIR)/usr/lib/libvorbis.so: $(LIBVORBIS_DIR)/.libs
- $(MAKE) prefix=$(TARGET_DIR)/usr -C $(LIBVORBIS_DIR) install
- touch $@
+$(STAGING_DIR)/usr/lib/libvorbis.so: $(LIBVORBIS_DIR)/.libs
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBVORBIS_DIR) install
+
+$(TARGET_DIR)/usr/lib/libvorbis.so: $(STAGING_DIR)/usr/lib/libvorbis.so
+ $(INSTALL) -D $(STAGING_DIR)/usr/lib/libvorbis*.so* $(TARGET_DIR)/usr/lib
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libvorbis*.so*
libvorbis: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/libvorbis.so