summaryrefslogtreecommitdiffstats
path: root/package/libvorbis
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-10-31 06:36:04 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-10-31 06:36:04 +0000
commit0e170adfa43b7e050671e537f06cbfcbb1e49686 (patch)
tree909bd7dc1294bb50b791d4ccb4236603049881e7 /package/libvorbis
parentd359c6611dc9232392c0545de6a783b4cff4e895 (diff)
downloadbuildroot-novena-0e170adfa43b7e050671e537f06cbfcbb1e49686.tar.gz
buildroot-novena-0e170adfa43b7e050671e537f06cbfcbb1e49686.zip
Fix Tremor (integer version of libvorbis) so it builds
Diffstat (limited to 'package/libvorbis')
-rw-r--r--package/libvorbis/Config.in4
-rw-r--r--package/libvorbis/libvorbis.mk14
2 files changed, 11 insertions, 7 deletions
diff --git a/package/libvorbis/Config.in b/package/libvorbis/Config.in
index 6ad0e2009..67deded69 100644
--- a/package/libvorbis/Config.in
+++ b/package/libvorbis/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_LIBVORBIS
bool "libvorbis"
default n
+ depends on BR2_PACKAGE_LIBOGG
help
Library for the Vorbis open source audio decoder
Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
@@ -29,3 +30,6 @@ config BR2_PACKAGE_LIBVORBIS_TREMOR
help
Use the Tremor fixed point implementation
Not yet implemented
+
+comment "libvorbis requires the package libogg to build"
+ depends on !BR2_PACKAGE_LIBVORBIS
diff --git a/package/libvorbis/libvorbis.mk b/package/libvorbis/libvorbis.mk
index a31d083e3..b6358778a 100644
--- a/package/libvorbis/libvorbis.mk
+++ b/package/libvorbis/libvorbis.mk
@@ -56,7 +56,7 @@ libvorbis-header: $(TARGET_DIR)/usr/lib/libvorbis.a
cp -dpf $(LIBVORBIS_DIR)/include/vorbis/*.h \
$(TARGET_DIR)/usr/include/vorbis
-libvorbis: uclibc pkgconfig $(TARGET_DIR)/usr/lib/libvorbis.so
+libvorbis: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/libvorbis.so
libvorbis-source: $(DL_DIR)/$(LIBVORBIS_SOURCE)
@@ -74,20 +74,20 @@ libvorbis-dirclean:
############################################################
TREMOR_TRUNK:=http://svn.xiph.org/trunk/Tremor/
-TREMOR_VERSION:=-svn-$(DATE)
+TREMOR_VERSION:=svn-$(DATE)
TREMOR_NAME:=Tremor-$(TREMOR_VERSION)
TREMOR_DIR:=$(BUILD_DIR)/$(TREMOR_NAME)
TREMOR_SOURCE:=$(TREMOR_NAME).tar.bz2
-
+TREMOR_CAT=$(BZCAT)
$(DL_DIR)/$(TREMOR_SOURCE):
(cd $(BUILD_DIR); \
$(SVN_CO) $(TREMOR_TRUNK); \
mv -f Tremor $(TREMOR_NAME); \
- tar -cvf $(TREMOR_NAME).tar $(TREMOR_DIR); \
+ tar -cvf $(TREMOR_NAME).tar $(TREMOR_NAME); \
bzip2 $(TREMOR_NAME).tar; \
rm -rf $(TREMOR_DIR); \
- mv $(TREMOR_NAME).tar.bz2 $(DL_DIR)/$(TREMOR_SOURCE); \
+ mv $(TREMOR_SOURCE) $(DL_DIR)/$(TREMOR_SOURCE); \
)
$(TREMOR_DIR)/.source: $(DL_DIR)/$(TREMOR_SOURCE)
@@ -99,7 +99,7 @@ $(TREMOR_DIR)/.configured: $(TREMOR_DIR)/.source
$(TARGET_CONFIGURE_ARGS) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
+ ./autogen.sh \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
@@ -129,7 +129,7 @@ tremor-header: $(TARGET_DIR)/usr/lib/tremor.a
cp -dpf $(TREMOR_DIR)/include/vorbis/*.h \
$(TARGET_DIR)/usr/include/vorbis
-tremor: uclibc pkgconfig $(TARGET_DIR)/usr/lib/tremor.so
+tremor: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/tremor.so
tremor-source: $(DL_DIR)/$(TREMOR_SOURCE)