summaryrefslogtreecommitdiffstats
path: root/package/libusb
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/libusb
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
downloadbuildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.tar.gz
buildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.zip
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/libusb')
-rw-r--r--package/libusb/Config.in1
-rw-r--r--package/libusb/libusb.mk2
2 files changed, 1 insertions, 2 deletions
diff --git a/package/libusb/Config.in b/package/libusb/Config.in
index 20f2556c7..7f7276fed 100644
--- a/package/libusb/Config.in
+++ b/package/libusb/Config.in
@@ -1,6 +1,5 @@
config BR2_PACKAGE_LIBUSB
bool "libusb"
- select BR2_PACKAGE_PKGCONFIG
help
Userspace library for accessing USB devices
diff --git a/package/libusb/libusb.mk b/package/libusb/libusb.mk
index 6a80d2671..bf831daea 100644
--- a/package/libusb/libusb.mk
+++ b/package/libusb/libusb.mk
@@ -58,7 +58,7 @@ $(TARGET_DIR)/$(LIBUSB_BINARY): $(STAGING_DIR)/usr/lib/libusb.so
cp -dpf $(STAGING_DIR)/usr/lib/libusb*.so* $(TARGET_DIR)/usr/lib/
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libusb*.so*
-libusb: uclibc pkgconfig $(TARGET_DIR)/$(LIBUSB_BINARY)
+libusb: uclibc host-pkgconfig $(TARGET_DIR)/$(LIBUSB_BINARY)
libusb-clean:
rm -f $(STAGING_DIR)/bin/libusb-config