summaryrefslogtreecommitdiffstats
path: root/package/libusb
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-14 18:32:17 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-14 18:32:17 +0000
commit5d37fc60951970cec58da0c2696a891a01991bbd (patch)
tree978223523866a7c2306c6de212c1388fd0f56027 /package/libusb
parentd9d199af65f53e6722164a1880fa9b9969b401b8 (diff)
downloadbuildroot-novena-5d37fc60951970cec58da0c2696a891a01991bbd.tar.gz
buildroot-novena-5d37fc60951970cec58da0c2696a891a01991bbd.zip
bug 834: libusb: build fix: set big/little endian
The following patch fixes a compilation error in libusb (cannot detectect endian while cross compiling)
Diffstat (limited to 'package/libusb')
-rw-r--r--package/libusb/libusb.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/libusb/libusb.mk b/package/libusb/libusb.mk
index 0fbb3bf28..9cb0d3fc8 100644
--- a/package/libusb/libusb.mk
+++ b/package/libusb/libusb.mk
@@ -11,6 +11,12 @@ LIBUSB_CAT:=zcat
LIBUSB_BINARY:=libusb.la
LIBUSB_TARGET_BINARY:=usr/lib/libusb.so
+ifeq ($(BR2_ENDIAN),"BIG")
+LIBUSB_BE:=yes
+else
+LIBUSB_BE:=no
+endif
+
$(DL_DIR)/$(LIBUSB_SOURCE):
$(WGET) -P $(DL_DIR) $(LIBUSB_SITE)/$(LIBUSB_SOURCE)
@@ -24,6 +30,7 @@ $(LIBUSB_DIR)/.configured: $(LIBUSB_DIR)/.unpacked
$(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD=$(HOSTCC) \
CFLAGS="$(TARGET_CFLAGS)" \
ac_cv_header_regex_h=no \
+ ac_cv_c_bigendian=$(LIBUSB_BE) \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \