summaryrefslogtreecommitdiffstats
path: root/package/libtorrent
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-05-14 10:55:28 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-14 23:00:56 +0200
commitbe26c3e760d86dbcc45ce6edd9e266a623c0430d (patch)
treeecb3329312d7a77c1a6f5338b0b8e9c77af4983f /package/libtorrent
parent5c884eb7bf6fd5ae1f1e5609b86897e7c2b70c92 (diff)
downloadbuildroot-novena-be26c3e760d86dbcc45ce6edd9e266a623c0430d.tar.gz
buildroot-novena-be26c3e760d86dbcc45ce6edd9e266a623c0430d.zip
libtorrent: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libtorrent')
-rw-r--r--package/libtorrent/Config.in11
-rw-r--r--package/libtorrent/libtorrent-cross_compile.patch27
-rw-r--r--package/libtorrent/libtorrent.mk16
3 files changed, 54 insertions, 0 deletions
diff --git a/package/libtorrent/Config.in b/package/libtorrent/Config.in
new file mode 100644
index 000000000..f0315a4f3
--- /dev/null
+++ b/package/libtorrent/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBTORRENT
+ bool "libtorrent"
+ depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_LIBSIGC
+ help
+ BitTorrent library written in C++ for *nix
+
+ http://libtorrent.rakshasa.no/
+
+comment "libtorrent requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/libtorrent/libtorrent-cross_compile.patch b/package/libtorrent/libtorrent-cross_compile.patch
new file mode 100644
index 000000000..39fe700dc
--- /dev/null
+++ b/package/libtorrent/libtorrent-cross_compile.patch
@@ -0,0 +1,27 @@
+Fix cross compilation, based on OpenWRT patch.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura libtorrent-0.13.2/configure.ac libtorrent-0.13.2-cross/configure.ac
+--- libtorrent-0.13.2/configure.ac 2012-04-20 03:55:10.000000000 -0300
++++ libtorrent-0.13.2-cross/configure.ac 2012-05-09 10:57:49.671175421 -0300
+@@ -17,7 +17,6 @@
+
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+ AC_DISABLE_STATIC
+
+ AM_DISABLE_STATIC
+diff -Nura libtorrent-0.13.2/scripts/checks.m4 libtorrent-0.13.2-cross/scripts/checks.m4
+--- libtorrent-0.13.2/scripts/checks.m4 2012-04-12 06:44:23.000000000 -0300
++++ libtorrent-0.13.2-cross/scripts/checks.m4 2012-05-09 10:42:32.642728917 -0300
+@@ -96,7 +96,7 @@
+ AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [
+ AC_MSG_CHECKING(whether kqueue supports pipes and ptys)
+
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <fcntl.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/package/libtorrent/libtorrent.mk b/package/libtorrent/libtorrent.mk
new file mode 100644
index 000000000..100e68465
--- /dev/null
+++ b/package/libtorrent/libtorrent.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libtorrent
+#
+#############################################################
+
+LIBTORRENT_VERSION = 0.13.2
+LIBTORRENT_SITE = http://libtorrent.rakshasa.no/downloads
+LIBTORRENT_DEPENDENCIES = host-pkg-config libsigc \
+ $(if $(BR2_PACKAGE_OPENSSL),openssl)
+LIBTORRENT_CONF_OPT = --enable-aligned \
+ $(if $(BR2_PACKAGE_OPENSSL),--enable-openssl,--disable-openssl)
+LIBTORRENT_INSTALL_STAGING = YES
+LIBTORRENT_AUTORECONF = YES
+
+$(eval $(call AUTOTARGETS))