summaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/libtool
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/Makefile.in3
-rw-r--r--package/libtool/libtool.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/libtool/Makefile.in b/package/libtool/Makefile.in
deleted file mode 100644
index 37f77548f..000000000
--- a/package/libtool/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_LIBTOOL)),y)
-TARGETS+=libtool
-endif
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index 2978ac09b..1758268c4 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -75,3 +75,11 @@ libtool-clean:
libtool-dirclean:
rm -rf $(LIBTOOL_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBTOOL)),y)
+TARGETS+=libtool
+endif