summaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-09-22 08:11:02 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-09-22 08:11:02 +0000
commit681f7022fa5e54ddd7fe2096763515efe6519dec (patch)
treeb1847ac6584877981d275c3698adfdb7b6ae182a /package/libtool
parent52097d2dad0f4fb832ece0aab44c1d08b583d4e8 (diff)
downloadbuildroot-novena-681f7022fa5e54ddd7fe2096763515efe6519dec.tar.gz
buildroot-novena-681f7022fa5e54ddd7fe2096763515efe6519dec.zip
libtool: don't error on missing directories in clean targets
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/libtool.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index 20b300a8d..238bfa6f8 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -90,7 +90,7 @@ endif
libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
libtool-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
+ -$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
-$(MAKE) -C $(LIBTOOL_DIR) clean
libtool-cross: uclibc $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
@@ -138,7 +138,7 @@ endif
host-libtool: $(LIBTOOL)
host-libtool-clean:
- $(MAKE) -C $(LIBTOOL_HOST_DIR) uninstall
+ -$(MAKE) -C $(LIBTOOL_HOST_DIR) uninstall
-$(MAKE) -C $(LIBTOOL_HOST_DIR) clean
host-libtool-dirclean: