summaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-29 19:10:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-29 19:10:26 +0000
commit6099e286e2b254517bb8ec63cad5131b1dc9539b (patch)
treedc928c090b28cfaac1c2dea3a37fbd047b837767 /package/libtool
parentfb56c53e3938c6a2911b4bb22b82219aa5943dce (diff)
downloadbuildroot-novena-6099e286e2b254517bb8ec63cad5131b1dc9539b.tar.gz
buildroot-novena-6099e286e2b254517bb8ec63cad5131b1dc9539b.zip
package: proper aclocal fix
Revert r25827 and instead copy over the host aclocal files of the stuff needed for auto* (libtool + pkgconfig). These logically belong with the target stuff, as they are used for the target auto* toolchain. Long term we should probably consider using aclocal --acdir=$(STAGING_DIR)/usr/share/aclocal, so the host .m4 files cannot interfere with the target build.
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/libtool.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index a649a7435..1f56fdd3b 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -49,6 +49,10 @@ $(STAMP_DIR)/host_libtool_compiled: $(STAMP_DIR)/host_libtool_configured
$(STAMP_DIR)/host_libtool_installed: $(STAMP_DIR)/host_libtool_compiled
$(MAKE) -C $(LIBTOOL_HOST_DIR) install
+ install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/libtool.m4 \
+ $(STAGING_DIR)/usr/share/aclocal/libtool.m4
+ install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/ltdl.m4 \
+ $(STAGING_DIR)/usr/share/aclocal/ltdl.m4
touch $@
host-libtool: $(STAMP_DIR)/host_libtool_installed