summaryrefslogtreecommitdiffstats
path: root/package/libsysfs
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-04-26 06:26:14 +0000
committerEric Andersen <andersen@codepoet.org>2005-04-26 06:26:14 +0000
commitdfba3cfed987daba1cf8f2e80286127afce7e651 (patch)
treef3822606cb3f07472eee73f4c853c462c171dbb7 /package/libsysfs
parentd17c8983f2923e1dd9b3c626e697733874f3151d (diff)
downloadbuildroot-novena-dfba3cfed987daba1cf8f2e80286127afce7e651.tar.gz
buildroot-novena-dfba3cfed987daba1cf8f2e80286127afce7e651.zip
http://bugs.uclibc.org/view.php?id=189
Diffstat (limited to 'package/libsysfs')
-rw-r--r--package/libsysfs/Config.in7
-rw-r--r--package/libsysfs/libsysfs.mk73
2 files changed, 80 insertions, 0 deletions
diff --git a/package/libsysfs/Config.in b/package/libsysfs/Config.in
new file mode 100644
index 000000000..418ca8d2b
--- /dev/null
+++ b/package/libsysfs/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBSYSFS
+ bool "libsysfs"
+ default n
+ help
+ These are a set of utilites built upon sysfs, a new virtual filesystem in Linux kernel versions 2.5+ that exposes a system's device tree.
+
+ http://linux-diag.sourceforge.net/Sysfsutils.html
diff --git a/package/libsysfs/libsysfs.mk b/package/libsysfs/libsysfs.mk
new file mode 100644
index 000000000..14aa8943e
--- /dev/null
+++ b/package/libsysfs/libsysfs.mk
@@ -0,0 +1,73 @@
+#############################################################
+#
+# libsysfs
+#
+#############################################################
+# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+LIBSYSFS_VER:=1.2.0
+LIBSYSFS_DIR:=$(BUILD_DIR)/sysfsutils-$(LIBSYSFS_VER)
+LIBSYSFS_SITE:=http://cogent.dl.sourceforge.net/sourceforge/linux-diag
+LIBSYSFS_SOURCE:=sysfsutils-$(LIBSYSFS_VER).tar.gz
+LIBSYSFS_CAT:=zcat
+
+$(DL_DIR)/$(LIBSYSFS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LIBSYSFS_SITE)/$(LIBSYSFS_SOURCE)
+
+libsysfs-source: $(DL_DIR)/$(LIBSYSFS_SOURCE)
+
+$(LIBSYSFS_DIR)/.unpacked: $(DL_DIR)/$(LIBSYSFS_SOURCE)
+ $(LIBSYSFS_CAT) $(DL_DIR)/$(LIBSYSFS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(LIBSYSFS_DIR)/.unpacked
+
+$(LIBSYSFS_DIR)/.configured: $(LIBSYSFS_DIR)/.unpacked
+ (cd $(LIBSYSFS_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) " \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/ );
+ touch $(LIBSYSFS_DIR)/.configured
+
+$(LIBSYSFS_DIR)/.compiled: $(LIBSYSFS_DIR)/.configured
+ $(MAKE) -C $(LIBSYSFS_DIR)
+ touch $(LIBSYSFS_DIR)/.compiled
+
+$(STAGING_DIR)/lib/libsysfs.so: $(LIBSYSFS_DIR)/.compiled
+ $(MAKE) -C $(LIBSYSFS_DIR) DESTDIR=$(STAGING_DIR) install
+ touch -c $(STAGING_DIR)/lib/libsysfs.so
+
+$(TARGET_DIR)/usr/lib/libsysfs.so: $(STAGING_DIR)/lib/libsysfs.so
+ cp -dpf $(STAGING_DIR)/lib/libsysfs.so* $(TARGET_DIR)/usr/lib/
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/lib/libsysfs.so
+
+libsysfs: uclibc $(TARGET_DIR)/usr/lib/libsysfs.so
+
+libsysfs-clean:
+ -$(MAKE) -C $(LIBSYSFS_DIR) clean
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBSYSFS)),y)
+TARGETS+=libsysfs
+endif