summaryrefslogtreecommitdiffstats
path: root/package/libsoup
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-04-26 21:40:32 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-04-26 21:40:32 +0000
commit2f094a92471250e2d70c7f42799239c30aa45c53 (patch)
tree5bc39997047c8ccc337fd3b16a3d755a5b58f734 /package/libsoup
parent4a653c39d4e29dae142129dd4edeef51fc45a266 (diff)
downloadbuildroot-novena-2f094a92471250e2d70c7f42799239c30aa45c53.tar.gz
buildroot-novena-2f094a92471250e2d70c7f42799239c30aa45c53.zip
package: add libsoup package
Based on patch by Sven Neumann <s.neumann@phase-zero.de>, closes #35.
Diffstat (limited to 'package/libsoup')
-rw-r--r--package/libsoup/Config.in10
-rw-r--r--package/libsoup/libsoup.mk30
2 files changed, 40 insertions, 0 deletions
diff --git a/package/libsoup/Config.in b/package/libsoup/Config.in
new file mode 100644
index 000000000..6bccd1116
--- /dev/null
+++ b/package/libsoup/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBSOUP
+ bool "libsoup"
+ select BR2_PACKAGE_LIBXML2
+ select BR2_PACKAGE_LIBGLIB2
+ help
+ libsoup is an HTTP client/server library. It uses GObject
+ and the GLib main loop, to integrate well with GNOME
+ applications.
+
+ http://live.gnome.org/LibSoup
diff --git a/package/libsoup/libsoup.mk b/package/libsoup/libsoup.mk
new file mode 100644
index 000000000..f9e9331d0
--- /dev/null
+++ b/package/libsoup/libsoup.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# libsoup
+#
+#############################################################
+
+LIBSOUP_VERSION:=2.4.1
+LIBSOUP_SOURCE:=libsoup-$(LIBSOUP_VERSION).tar.gz
+LIBSOUP_SITE:=http://ftp.gnome.org/pub/gnome/sources/libsoup/2.4
+LIBSOUP_AUTORECONF = NO
+LIBSOUP_INSTALL_STAGING = YES
+LIBSOUP_INSTALL_TARGET = YES
+
+LIBSOUP_CONF_ENV = \
+ ac_cv_path_GLIB_GENMARSHAL=$(HOST_GLIB)/bin/glib-genmarshal
+
+ifneq ($(BR2_INET_IPV6),y)
+LIBSOUP_CONF_ENV += soup_cv_ipv6=no
+endif
+
+LIBSOUP_CONF_OPT = \
+ --enable-shared \
+ --enable-static \
+ --disable-explicit-deps \
+ --disable-glibtest \
+ --disable-gtk-doc --without-html-dir
+
+LIBSOUP_DEPENDENCIES = uclibc gettext libintl host-pkgconfig host-libglib2 libglib2 libxml2
+
+$(eval $(call AUTOTARGETS,package,libsoup))