summaryrefslogtreecommitdiffstats
path: root/package/libsigc
diff options
context:
space:
mode:
authorH Hartley Sweeten <hartleys@visionengravers.com>2010-11-29 18:22:20 -0700
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-15 16:23:06 +0100
commitb98e4d001cb8073fa8aefd2193fd70df0274d05e (patch)
tree83e6d4208e769f1b45bd6cb76363a5a75f6ce417 /package/libsigc
parente5e5f5d8684a23f774baf57e1f75281e9a6519bd (diff)
downloadbuildroot-novena-b98e4d001cb8073fa8aefd2193fd70df0274d05e.tar.gz
buildroot-novena-b98e4d001cb8073fa8aefd2193fd70df0274d05e.zip
package: Add libsigc++ package
Add support for the libsigc++ library. [Peter: Rename dir, use libtool patch, add C++ dep] Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libsigc')
-rw-r--r--package/libsigc/Config.in13
-rw-r--r--package/libsigc/libsigc.mk11
2 files changed, 24 insertions, 0 deletions
diff --git a/package/libsigc/Config.in b/package/libsigc/Config.in
new file mode 100644
index 000000000..93fa3f414
--- /dev/null
+++ b/package/libsigc/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBSIGC
+ bool "libsigc++"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ libsigc++ implements a typesafe callback system for standard C++.
+ It allows you to define signals and to connect those signals to
+ any callback function, either global or a member function,
+ regardless of whether it is static or virtual.
+
+ http://libsigc.sourceforge.net/
+
+comment "libsigc++ requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/libsigc/libsigc.mk b/package/libsigc/libsigc.mk
new file mode 100644
index 000000000..0b1de1466
--- /dev/null
+++ b/package/libsigc/libsigc.mk
@@ -0,0 +1,11 @@
+#############################################################
+#
+# libsigc++
+#
+#############################################################
+LIBSIGC_VERSION = 2.2.8
+LIBSIGC_SOURCE = libsigc++-$(LIBSIGC_VERSION).tar.bz2
+LIBSIGC_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2
+LIBSIGC_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,package,libsigc))