summaryrefslogtreecommitdiffstats
path: root/package/librsync
diff options
context:
space:
mode:
authorChris Seawood <cls@seawood.org>2010-03-22 16:50:51 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-03-22 17:27:13 +0100
commita038602e8239bed895644bb0266542ae10ba8e69 (patch)
tree31649a64438c42c30ed2f8338ee6bba63be7cf3e /package/librsync
parentd6a2fa87b8e6b131b1ad52f9f586605db95607ed (diff)
downloadbuildroot-novena-a038602e8239bed895644bb0266542ae10ba8e69.tar.gz
buildroot-novena-a038602e8239bed895644bb0266542ae10ba8e69.zip
package: add librsync
Closes #1303 [Peter: misc tweaks (whitespace, kconfig, sf.net URL)] Signed-off-by: Chris Seawood <cls@seawood.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/librsync')
-rw-r--r--package/librsync/Config.in11
-rw-r--r--package/librsync/librsync.mk15
2 files changed, 26 insertions, 0 deletions
diff --git a/package/librsync/Config.in b/package/librsync/Config.in
new file mode 100644
index 000000000..5dcdfc8f2
--- /dev/null
+++ b/package/librsync/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBRSYNC
+ bool "librsync"
+ select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_BZIP2
+ select BR2_PACKAGE_POPT
+ help
+ librsync implements the rolling-checksum algorithm of
+ remote file synchronization that was popularized by the
+ rsync utility and is used in rproxy.
+
+ http://sourceforge.net/projects/librsync/
diff --git a/package/librsync/librsync.mk b/package/librsync/librsync.mk
new file mode 100644
index 000000000..3db4625c8
--- /dev/null
+++ b/package/librsync/librsync.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# librsync
+#
+#############################################################
+LIBRSYNC_VERSION:=0.9.7
+LIBRSYNC_SOURCE:=librsync-$(LIBRSYNC_VERSION).tar.gz
+LIBRSYNC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/librsync/
+LIBRSYNC_INSTALL_STAGING = YES
+LIBRSYNC_INSTALL_TARGET = YES
+LIBRSYNC_CONF_OPT = --enable-shared
+
+LIBRSYNC_DEPENDENCIES = zlib bzip2 popt
+
+$(eval $(call AUTOTARGETS,package,librsync))