summaryrefslogtreecommitdiffstats
path: root/package/libroxml
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 12:44:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 12:57:54 +0200
commitb28de60c24ad4bef4ff7a6ad51cbb6e79906c868 (patch)
tree39bb6bfc5ff2ef5fb9afafd864cbc3cac4009b9b /package/libroxml
parentb51b664727458235460ed3c5429b8d44215b9446 (diff)
downloadbuildroot-novena-b28de60c24ad4bef4ff7a6ad51cbb6e79906c868.tar.gz
buildroot-novena-b28de60c24ad4bef4ff7a6ad51cbb6e79906c868.zip
package: add libroxml
Closes #3595 Based on patch by Tristan Lelong <tristan.lelong@blunderer.org>. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libroxml')
-rw-r--r--package/libroxml/Config.in8
-rw-r--r--package/libroxml/libroxml-2.0.3-fix-install.patch25
-rw-r--r--package/libroxml/libroxml.mk33
3 files changed, 66 insertions, 0 deletions
diff --git a/package/libroxml/Config.in b/package/libroxml/Config.in
new file mode 100644
index 000000000..e26d239f8
--- /dev/null
+++ b/package/libroxml/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBROXML
+ bool "roxml"
+ help
+ libroxml is a light and powerful xml parsing library with
+ xpath handling. Roxml is a binary using libroxml to explore
+ xml file from shell scripts.
+
+ http://libroxml.googlecode.com
diff --git a/package/libroxml/libroxml-2.0.3-fix-install.patch b/package/libroxml/libroxml-2.0.3-fix-install.patch
new file mode 100644
index 000000000..fe3cfad8f
--- /dev/null
+++ b/package/libroxml/libroxml-2.0.3-fix-install.patch
@@ -0,0 +1,25 @@
+[PATCH] fix make install if doxygen isn't available
+
+If doxygen isn't available, then man pages / html docs won't get created,
+so don't try to install them.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: libroxml-2.0.3/Makefile
+===================================================================
+--- libroxml-2.0.3.orig/Makefile
++++ libroxml-2.0.3/Makefile
+@@ -153,8 +153,8 @@
+ $E install -D $(INC) $(DESTDIR)/usr/include
+ $E install -D LGPL.txt $(DESTDIR)/usr/share/doc/libroxml/
+ $E install -D docs/roxml.1 $(DESTDIR)/usr/share/man/man1/
+- $E install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
+- $E install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
++ $E [ ! -d docs/man/man3 ] || install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
++ $E [ ! -d docs/html ] || install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
+ $E install -m644 libroxml.pc $(DESTDIR)/usr/lib/pkgconfig
+ $E cp -d $(TARGET_LN) $(DESTDIR)/usr/lib
+
diff --git a/package/libroxml/libroxml.mk b/package/libroxml/libroxml.mk
new file mode 100644
index 000000000..bf067dfd7
--- /dev/null
+++ b/package/libroxml/libroxml.mk
@@ -0,0 +1,33 @@
+#
+# libroxml
+#
+
+LIBROXML_VERSION = 2.0.3
+LIBROXML_SITE = http://libroxml.googlecode.com/files
+LIBROXML_INSTALL_STAGING = YES
+
+define LIBROXML_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) OPTIM= -C $(@D) V=1 all
+endef
+
+define LIBROXML_INSTALL_STAGING_CMDS
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) install
+endef
+
+define LIBROXML_INSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+define LIBROXML_UNINSTALL_STAGING_CMDS
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) uninstall
+endef
+
+define LIBROXML_UNINSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) uninstall
+endef
+
+define LIBROXML_CLEAN_CMDS
+ -$(MAKE) -C $(@D) clean
+endef
+
+$(eval $(call GENTARGETS,package,libroxml))