summaryrefslogtreecommitdiffstats
path: root/package/libraw1394
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-25 08:58:38 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-25 08:58:38 +0000
commitb63654f3520fd5182814466aec79d41f0def4753 (patch)
tree3a4bb2875d20999079cf068406471ec725dc7755 /package/libraw1394
parenta56ecc4aeef9b34d2124b60d718f46d7c7806361 (diff)
downloadbuildroot-novena-b63654f3520fd5182814466aec79d41f0def4753.tar.gz
buildroot-novena-b63654f3520fd5182814466aec79d41f0def4753.zip
- Install the library under $(STAGING_DIR)/usr/lib (Julien Letessier)
Diffstat (limited to 'package/libraw1394')
-rw-r--r--package/libraw1394/libraw1394.mk20
1 files changed, 9 insertions, 11 deletions
diff --git a/package/libraw1394/libraw1394.mk b/package/libraw1394/libraw1394.mk
index 0d8427134..e4d78f8dd 100644
--- a/package/libraw1394/libraw1394.mk
+++ b/package/libraw1394/libraw1394.mk
@@ -12,15 +12,13 @@ LIBRAW1394_DIR:=$(BUILD_DIR)/libraw1394-$(LIBRAW1394_VERSION)
$(DL_DIR)/$(LIBRAW1394_SOURCE):
$(WGET) -P $(DL_DIR) $(LIBRAW1394_SITE)/$(LIBRAW1394_SOURCE)
-$(LIBRAW1394_DIR)/.source: $(DL_DIR)/$(LIBRAW1394_SOURCE)
+$(LIBRAW1394_DIR)/.unpacked: $(DL_DIR)/$(LIBRAW1394_SOURCE)
$(ZCAT) $(DL_DIR)/$(LIBRAW1394_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(LIBRAW1394_DIR)/.source
+ touch $@
-$(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.source
- (cd $(LIBRAW1394_DIR); \
+$(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.unpacked
+ (cd $(LIBRAW1394_DIR); rm -rf config.cache ; \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -29,7 +27,7 @@ $(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.source
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
- --libdir=/lib \
+ --libdir=/usr/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
@@ -38,17 +36,17 @@ $(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.source
--mandir=/usr/man \
--infodir=/usr/info \
);
- touch $(LIBRAW1394_DIR)/.configured;
+ touch $@
$(LIBRAW1394_DIR)/.compiled: $(LIBRAW1394_DIR)/.configured
$(MAKE) -C $(LIBRAW1394_DIR)
- touch $(LIBRAW1394_DIR)/.compiled
+ touch $@
-$(STAGING_DIR)/lib/libraw1394.so: $(LIBRAW1394_DIR)/.compiled
+$(STAGING_DIR)/usr/lib/libraw1394.so: $(LIBRAW1394_DIR)/.compiled
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBRAW1394_DIR)/src install
$(TARGET_DIR)/usr/lib/libraw1394.so: $(STAGING_DIR)/lib/libraw1394.so
- cp -dpf $(STAGING_DIR)/lib/libraw1394.so* $(TARGET_DIR)/usr/lib/
+ cp -dpf $(STAGING_DIR)/usr/lib/libraw1394.so* $(TARGET_DIR)/usr/lib/
libraw1394: uclibc $(TARGET_DIR)/usr/lib/libraw1394.so