summaryrefslogtreecommitdiffstats
path: root/package/libpthsem
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2013-03-24 11:34:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 22:54:49 +0100
commit468e9595be307b06ffd8bdcd6b7cac624e6549cc (patch)
tree07170a06e455823a7ce9ed13b9b45a8e4a92c177 /package/libpthsem
parent3400663620e039427c704f6c73b061d23ac54a4a (diff)
downloadbuildroot-novena-468e9595be307b06ffd8bdcd6b7cac624e6549cc.tar.gz
buildroot-novena-468e9595be307b06ffd8bdcd6b7cac624e6549cc.zip
libpthsem: new package
[Peter: remove extra newlines] [Thomas: various fixes/improvements] Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libpthsem')
-rw-r--r--package/libpthsem/Config.in8
-rw-r--r--package/libpthsem/libpthsem-2.0.8-fix-build-on-linux-3.x-host.patch28
-rw-r--r--package/libpthsem/libpthsem.mk17
3 files changed, 53 insertions, 0 deletions
diff --git a/package/libpthsem/Config.in b/package/libpthsem/Config.in
new file mode 100644
index 000000000..9ab13c3ed
--- /dev/null
+++ b/package/libpthsem/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBPTHSEM
+ bool "libpthsem"
+ select BR2_PACKAGE_ARGP_STANDALONE
+ help
+ GNU pth is a user mode multi threading library. pthsem is an extend
+ version, with support for semaphores added.
+
+ http://www.auto.tuwien.ac.at/~mkoegler/pth/
diff --git a/package/libpthsem/libpthsem-2.0.8-fix-build-on-linux-3.x-host.patch b/package/libpthsem/libpthsem-2.0.8-fix-build-on-linux-3.x-host.patch
new file mode 100644
index 000000000..21fff4e7c
--- /dev/null
+++ b/package/libpthsem/libpthsem-2.0.8-fix-build-on-linux-3.x-host.patch
@@ -0,0 +1,28 @@
+From 2d0450bfa3fb7003098da1a7fe24c3ae140912dc Mon Sep 17 00:00:00 2001
+From: Gregory Hermant <gregory.hermant@calao-systems.com>
+Date: Mon, 22 Oct 2012 15:11:53 +0200
+Subject: [PATCH] pthsem build on Linux 3.x host
+
+
+Signed-off-by: Michael Markstaller <mm@elabnet.de>
+Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com>
+---
+ acinclude.m4 | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 03b42de..fea9bc8 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -892,6 +892,8 @@ case $PLATFORM in
+ case "x`uname -r`" in
+ changequote(, )dnl
+ x2.[23456789]* ) ;;
++changequote(, )dnl
++ x3.* ) ;;
+ changequote([, ])
+ * ) braindead=yes ;;
+ esac
+--
+1.7.9.5
+
diff --git a/package/libpthsem/libpthsem.mk b/package/libpthsem/libpthsem.mk
new file mode 100644
index 000000000..2c6e239c9
--- /dev/null
+++ b/package/libpthsem/libpthsem.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# libpthsem
+#
+#############################################################
+
+LIBPTHSEM_VERSION = 2.0.8
+LIBPTHSEM_SOURCE = pthsem_$(LIBPTHSEM_VERSION).tar.gz
+LIBPTHSEM_SITE = http://www.auto.tuwien.ac.at/~mkoegler/pth/
+LIBPTHSEM_LICENSE = LGPLv2.1+
+LIBPTHSEM_LICENSE_FILES = COPYING
+LIBPTHSEM_AUTORECONF = YES
+LIBPTHSEM_INSTALL_STAGING = YES
+LIBPTHSEM_DEPENDENCIES = argp-standalone
+LIBPTHSEM_CONFIG_SCRIPTS = pthsem-config
+
+$(eval $(autotools-package))