summaryrefslogtreecommitdiffstats
path: root/package/libplayer
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-30 03:48:15 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 23:40:27 +0200
commit84d589a963d902849b7022091e97ec71c38ed82e (patch)
tree121dfa6b27d4e3645ce1c6a09c4fbc295d461d0c /package/libplayer
parent33f454bbef77638a29ec24807e30740323e15b3e (diff)
downloadbuildroot-novena-84d589a963d902849b7022091e97ec71c38ed82e.tar.gz
buildroot-novena-84d589a963d902849b7022091e97ec71c38ed82e.zip
package/multimedia: move multimedia libraries out
Move multimedia libraries ouf of the Audio and Video category into the Libraries/Multimedia one. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libplayer')
-rw-r--r--package/libplayer/Config.in31
-rw-r--r--package/libplayer/libplayer.mk44
2 files changed, 75 insertions, 0 deletions
diff --git a/package/libplayer/Config.in b/package/libplayer/Config.in
new file mode 100644
index 000000000..fe851ac6b
--- /dev/null
+++ b/package/libplayer/Config.in
@@ -0,0 +1,31 @@
+config BR2_PACKAGE_LIBPLAYER
+ depends on BR2_LARGEFILE
+ bool "libplayer"
+ help
+ libplayer provides a generic A/V API that relies on various multimedia
+ player for Linux systems. It currently supports MPlayer, xine VLC and
+ GStreamer only
+
+ http://libplayer.geexbox.org/
+
+if BR2_PACKAGE_LIBPLAYER
+config BR2_PACKAGE_LIBPLAYER_MPLAYER
+ bool "mplayer backend"
+ select BR2_PACKAGE_MPLAYER
+
+config BR2_PACKAGE_LIBPLAYER_GSTREAMER
+ bool "gstreamer backend"
+ depends on BR2_USE_WCHAR # glib2
+ select BR2_PACKAGE_GSTREAMER
+
+comment "gstreamer backend requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
+
+config BR2_PACKAGE_LIBPLAYER_PYTHON
+ depends on BR2_PACKAGE_PYTHON
+ depends on BROKEN # player_init params, builds for host
+ bool "Libplayer python bindings"
+endif
+
+comment "libplayer requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/libplayer/libplayer.mk b/package/libplayer/libplayer.mk
new file mode 100644
index 000000000..093821e40
--- /dev/null
+++ b/package/libplayer/libplayer.mk
@@ -0,0 +1,44 @@
+#############################################################
+#
+# libplayer
+#
+#############################################################
+LIBPLAYER_VERSION = 2.0.1
+LIBPLAYER_SITE = http://libplayer.geexbox.org/releases/
+LIBPLAYER_SOURCE = libplayer-$(LIBPLAYER_VERSION).tar.bz2
+
+# When passing the standard buildroot configure arguments, the configure script
+# breaks on --target and --host options. Thus we need to define a configure cmd
+# ourselves.
+define LIBPLAYER_CONFIGURE_CMDS
+ (cd $(@D) && rm -rf config.cache && \
+ $(TARGET_CONFIGURE_OPTS) \
+ $(TARGET_CONFIGURE_ARGS) \
+ ./configure \
+ --prefix=/usr \
+ --cross-compile \
+ $(SHARED_STATIC_LIBS_OPTS) \
+ $(QUIET) $(LIBPLAYER_CONF_OPT) \
+ )
+endef
+
+ifeq ($(BR2_PACKAGE_LIBPLAYER_MPLAYER),y)
+ LIBPLAYER_DEPENDENCIES += mplayer
+ LIBPLAYER_CONF_OPT += --enable-mplayer
+else
+ LIBPLAYER_CONF_OPT += --disable-mplayer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPLAYER_GSTREAMER),y)
+ LIBPLAYER_DEPENDENCIES += gstreamer
+ LIBPLAYER_CONF_OPT += --enable-gstreamer
+else
+ LIBPLAYER_CONF_OPT += --disable-gstreamer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPLAYER_PYTHON),y)
+ LIBPLAYER_DEPENDENCIES += python
+ LIBPLAYER_CONF_OPT += --enable-binding-python
+endif
+
+$(eval $(call AUTOTARGETS))