summaryrefslogtreecommitdiffstats
path: root/package/libplayer
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-05-07 05:15:59 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-07 21:42:53 +0200
commit7f4f99ee78ad559512d8f9c11b4e0ead11ac035d (patch)
tree75322fd0638be1693dbe14780dc602bdec704090 /package/libplayer
parentefe0daab8cfef743c282b437c44c35cba7905d44 (diff)
downloadbuildroot-novena-7f4f99ee78ad559512d8f9c11b4e0ead11ac035d.tar.gz
buildroot-novena-7f4f99ee78ad559512d8f9c11b4e0ead11ac035d.zip
libplayer: add patch to fix build issue
Fixes http://autobuild.buildroot.org/results/af5e72c2385896f2bdb5c1b98efd487afb46a502/build-end.log. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libplayer')
-rw-r--r--package/libplayer/libplayer-add-fpic.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/libplayer/libplayer-add-fpic.patch b/package/libplayer/libplayer-add-fpic.patch
new file mode 100644
index 000000000..e4b227f91
--- /dev/null
+++ b/package/libplayer/libplayer-add-fpic.patch
@@ -0,0 +1,18 @@
+Add -fPIC to CFLAGS
+
+-fPIC is needed to build shared library code.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -9,6 +9,7 @@
+ SHARED_LIBNAME_VERSION = $(SHARED_LIBNAME).$(VERSION)
+ SHARED_LIBNAME_MAJOR = $(SHARED_LIBNAME).$(shell echo $(VERSION) | cut -f1 -d.)
+ SHARED_LIBNAME_FLAGS = -shared -Wl,-soname,$(SHARED_LIBNAME_MAJOR)
++CFLAGS = -fPIC
+
+ ifeq ($(BUILD_STATIC),yes)
+ BUILD_RULES += lib_static