summaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-06 09:41:52 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-06 09:41:52 -0800
commite63dcf20e2e457534346b144b32a2c4abe469a29 (patch)
treee7ec5be965c688a169902e6b2c07fefeec955ef5 /package/libpcap
parent7f77121fdde5a0c16d9b6968c71e982d3e953d25 (diff)
downloadbuildroot-novena-e63dcf20e2e457534346b144b32a2c4abe469a29.tar.gz
buildroot-novena-e63dcf20e2e457534346b144b32a2c4abe469a29.zip
libpcap: fix canusb related build issue
Fixes http://autobuild.buildroot.net/results/1b57e479a643df11ea3b20f848085af4ef40799b The libusb auto detection oddly enough succeeds, even though libusb isn't available. Fix it by explicitly enabling/disabling canusb support. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index d35c22824..7e68f5136 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -20,12 +20,18 @@ LIBPCAP_INSTALL_STAGING = YES
# configure script correctly handles --enable-shared/--disable-shared.
LIBPCAP_AUTORECONF = YES
-LIBPCAP_DEPENDENCIES = zlib \
- $(if $(BR2_PACKAGE_LIBUSB),libusb)
+LIBPCAP_DEPENDENCIES = zlib
LIBPCAP_CONF_ENV = ac_cv_linux_vers=2 \
ac_cv_header_linux_wireless_h=yes # configure misdetects this
LIBPCAP_CONF_OPT = --disable-yydebug --with-pcap=linux
+ifeq ($(BR2_PACKAGE_LIBUSB),y)
+LIBPCAP_CONF_OPT += --enable-canusb
+LIBPCAP_DEPENDENCIES += libusb
+else
+LIBPCAP_CONF_OPT += --disable-canusb
+endif
+
# microblaze needs -fPIC instead of -fpic
ifeq ($(BR2_microblaze),y)
LIBPCAP_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"