summaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/libpcap
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk23
1 files changed, 14 insertions, 9 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index d73c98511..4e657f302 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -48,6 +48,18 @@ $(LIBPCAP_DIR)/.configured: $(LIBPCAP_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--with-build-cc="$(HOSTCC)" \
--disable-yydebug \
--prefix=/usr \
@@ -56,19 +68,12 @@ $(LIBPCAP_DIR)/.configured: $(LIBPCAP_DIR)/.unpacked
touch $(LIBPCAP_DIR)/.configured
$(LIBPCAP_DIR)/libpcap.a: $(LIBPCAP_DIR)/.configured
- $(MAKE) \
- CC="$(TARGET_CC)" \
+ $(MAKE) CC="$(TARGET_CC)" \
AR="$(TARGET_CROSS)ar" \
-C $(LIBPCAP_DIR)
$(STAGING_DIR)/lib/libpcap.a: $(LIBPCAP_DIR)/libpcap.a
- $(MAKE) \
- -C $(LIBPCAP_DIR) \
- prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) \
- bindir=$(STAGING_DIR)/bin \
- datadir=$(STAGING_DIR)/share \
- install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBPCAP_DIR) install
libpcap: uclibc zlib $(STAGING_DIR)/lib/libpcap.a