summaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-25 09:46:58 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:23:22 +0100
commit4c6a451ac9fab16abcda5834ed4a9b728091ab9e (patch)
treee9f8aecf11b2b2d9630c2ea7bcb0cf5cc5c696ea /package/libpcap
parent58d107ec3fb77b05bc16911a04ca7d42c46eb4d5 (diff)
downloadbuildroot-novena-4c6a451ac9fab16abcda5834ed4a9b728091ab9e.tar.gz
buildroot-novena-4c6a451ac9fab16abcda5834ed4a9b728091ab9e.zip
tcpdump, libpcap: simplify and fix ac_cv_linux_vers
For some reason, tcpdump and libpcap need to have some information about the kernel version being used. This information is passed using the ac_cv_linux_vers autoconf variable. However, the current value is determined using BR2_DEFAULT_KERNEL_HEADERS which is only defined when an internal Buildroot toolchain is used. So it would break with an external toolchain or the Crosstool-NG backend. According to Mike Frysinger at http://lists.busybox.net/pipermail/buildroot/2011-January/040861.html, this value is only used to determine if the kernel version is 0.x, 1.x or 2.x, so passing ac_cv_linux_vers=2 is sufficient since Buildroot only supports the 2.6 kernel anyway. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index eebfc03d4..a2d0376b7 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -14,7 +14,7 @@ LIBPCAP_INSTALL_TARGET_OPT= DESTDIR="$(TARGET_DIR)" \
LIBPCAP_INSTALL_STAGING_OPT= DESTDIR="$(STAGING_DIR)" install \
$(if $(BR2_PREFER_STATIC_LIB),,install-shared)
LIBPCAP_DEPENDENCIES:=zlib
-LIBPCAP_CONF_ENV:=ac_cv_linux_vers=$(firstword $(subst .,$(space),$(firstword $(call qstrip,$(BR2_DEFAULT_KERNEL_HEADERS))))) \
+LIBPCAP_CONF_ENV:=ac_cv_linux_vers=2 \
ac_cv_header_linux_wireless_h=yes # configure misdetects this
LIBPCAP_CONF_OPT:=--disable-yydebug --with-pcap=linux