summaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2009-10-07 22:08:37 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-27 09:28:40 +0100
commit0575682552f5614d66cfa29deb70da0bba5e7d63 (patch)
treef545b2785ac296f82136bc78d1e57fe9b98bf304 /package/libpcap
parent434b007fce010a471c64164a3e22b13f4440159d (diff)
downloadbuildroot-novena-0575682552f5614d66cfa29deb70da0bba5e7d63.tar.gz
buildroot-novena-0575682552f5614d66cfa29deb70da0bba5e7d63.zip
libpcap, tcpdump: bump version and autotoolify
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk92
-rw-r--r--package/libpcap/libpcap.patch13
2 files changed, 17 insertions, 88 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index 491f9852a..272d646b3 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -3,83 +3,25 @@
# libpcap
#
#############################################################
-# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
-# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Library General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA
-LIBPCAP_VERSION:=0.9.8
-LIBPCAP_DIR:=$(BUILD_DIR)/libpcap-$(LIBPCAP_VERSION)
+LIBPCAP_VERSION:=1.0.0
LIBPCAP_SITE:=http://www.tcpdump.org/release
LIBPCAP_SOURCE:=libpcap-$(LIBPCAP_VERSION).tar.gz
-LIBPCAP_CAT:=$(ZCAT)
-
-$(DL_DIR)/$(LIBPCAP_SOURCE):
- $(call DOWNLOAD,$(LIBPCAP_SITE),$(LIBPCAP_SOURCE))
-
-libpcap-source: $(DL_DIR)/$(LIBPCAP_SOURCE)
-
-$(LIBPCAP_DIR)/.unpacked: $(DL_DIR)/$(LIBPCAP_SOURCE)
- $(LIBPCAP_CAT) $(DL_DIR)/$(LIBPCAP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- rm -f $(LIBPCAP_DIR)/gencode.c.rej
- toolchain/patch-kernel.sh $(LIBPCAP_DIR) package/libpcap/ \*.patch
- $(CONFIG_UPDATE) $(LIBPCAP_DIR)
- touch $@
-
-$(LIBPCAP_DIR)/.configured: $(LIBPCAP_DIR)/.unpacked
- (cd $(LIBPCAP_DIR); rm -rf config.cache; \
- ac_cv_linux_vers=$(BR2_DEFAULT_KERNEL_HEADERS) \
- BUILD_CC=$(TARGET_CC) HOSTCC="$(HOSTCC)" \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- ./configure $(QUIET) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-yydebug \
- --with-pcap=linux \
- $(DISABLE_IPV6) \
- )
+LIBPCAP_INSTALL_STAGING:=YES
+# doesn't have an install-strip
+LIBPCAP_INSTALL_TARGET_OPT= DESTDIR="$(TARGET_DIR)" \
+ $(if $(BR2_PREFER_STATIC_LIB),install,install-shared)
+LIBPCAP_INSTALL_STAGING_OPT= DESTDIR="$(STAGING_DIR)" \
+ $(if $(BR2_PREFER_STATIC_LIB),install,install-shared)
+LIBPCAP_DEPENDENCIES:=zlib
+LIBPCAP_CONF_ENV:=ac_cv_linux_vers=$(firstword $(subst .,$(space),$(firstword $(call qstrip,$(BR2_DEFAULT_KERNEL_HEADERS)))))
+LIBPCAP_CONF_OPT:=--disable-yydebug --with-pcap=linux
+
+$(eval $(call AUTOTARGETS,package,libpcap))
+
+$(LIBPCAP_HOOK_POST_INSTALL): $(LIBPCAP_TARGET_INSTALL_TARGET)
+ifeq ($(BR2_PREFER_STATIC_LIB),)
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(wildcard $(TARGET_DIR)/usr/lib/libpcap.so*)
+endif
touch $@
-$(LIBPCAP_DIR)/libpcap.a: $(LIBPCAP_DIR)/.configured
- $(MAKE) AR=$(TARGET_CROSS)ar -C $(LIBPCAP_DIR)
-
-$(STAGING_DIR)/usr/lib/libpcap.a: $(LIBPCAP_DIR)/libpcap.a
- $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBPCAP_DIR) install
-
-libpcap: zlib $(STAGING_DIR)/usr/lib/libpcap.a
-
-libpcap-clean:
- rm -f $(addprefix $(STAGING_DIR)/usr/,include/pcap*.h \
- lib/libpcap.a \
- share/man/man?/pcap.*)
- -$(MAKE) -C $(LIBPCAP_DIR) clean
-
-libpcap-dirclean:
- rm -rf $(LIBPCAP_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_LIBPCAP),y)
-TARGETS+=libpcap
-endif
diff --git a/package/libpcap/libpcap.patch b/package/libpcap/libpcap.patch
deleted file mode 100644
index 93206946b..000000000
--- a/package/libpcap/libpcap.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libpcap-0.9.8/Makefile.in
-===================================================================
---- libpcap-0.9.8.orig/Makefile.in 2007-07-24 04:35:15.000000000 +0200
-+++ libpcap-0.9.8/Makefile.in 2008-10-07 09:23:01.000000000 +0200
-@@ -103,7 +103,7 @@
-
- libpcap.a: $(OBJ)
- @rm -f $@
-- ar rc $@ $(OBJ) $(LIBS)
-+ $(AR) rc $@ $(OBJ) $(LIBS)
- $(RANLIB) $@
-
- shared: libpcap.$(DYEXT)